brcm63xx: convert RTA1320 to dts
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Feb 2015 17:39:21 +0000 (17:39 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Feb 2015 17:39:21 +0000 (17:39 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44563 3c298f89-4303-0410-b956-a3cf2f4a3e73

41 files changed:
target/linux/brcm63xx/dts/rta1320.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/509-board_rta1320_16m.patch
target/linux/brcm63xx/patches-3.14/510-board_spw303v.patch
target/linux/brcm63xx/patches-3.14/511-board_V2500V.patch
target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch
target/linux/brcm63xx/patches-3.14/516-board_96348A-122.patch
target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.18/509-board_rta1320_16m.patch
target/linux/brcm63xx/patches-3.18/510-board_spw303v.patch
target/linux/brcm63xx/patches-3.18/511-board_V2500V.patch
target/linux/brcm63xx/patches-3.18/514-board_ct536_ct5621.patch
target/linux/brcm63xx/patches-3.18/516-board_96348A-122.patch
target/linux/brcm63xx/patches-3.18/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.18/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.18/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.18/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.18/528-board_nb6.patch
target/linux/brcm63xx/patches-3.18/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.18/534-board_hw556.patch
target/linux/brcm63xx/patches-3.18/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.18/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.18/565-board_hw520.patch
target/linux/brcm63xx/profiles/dynalink.mk

diff --git a/target/linux/brcm63xx/dts/rta1320.dts b/target/linux/brcm63xx/dts/rta1320.dts
new file mode 100644 (file)
index 0000000..8b9620f
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6338.dtsi"
+
+/ {
+       model = "Dynalink RTA1320";
+       compatible = "dynalink,rta1320", "brcm,bcm6338";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x3e0000>;
+       };
+
+       nvram@3f0000 {
+               label = "nvram";
+               reg = <0x3f0000 0x010000>;
+       };
+};
index 16b5ade..d467d8c 100755 (executable)
@@ -201,8 +201,6 @@ define Image/Build
 
        # BT Voyager V2500V, V2500V_SIP_CLUB, V2500V_AA
        $(call Image/Build/CFE,$(1),V2500V_BB,6348,BTV2500V,,--layoutver 5)
 
        # BT Voyager V2500V, V2500V_SIP_CLUB, V2500V_AA
        $(call Image/Build/CFE,$(1),V2500V_BB,6348,BTV2500V,,--layoutver 5)
-       # RTA1320_16M (numerous routers)
-       $(call Image/Build/CFE,$(1),RTA1320_16M,6338,RTA1320_16M,,--layoutver 5)
 
        # build dtb image list
        $(foreach image,$(TARGET_$(PROFILE)_IMAGES),$(call Image/Build/$(image),$(1)))
 
        # build dtb image list
        $(foreach image,$(TARGET_$(PROFILE)_IMAGES),$(call Image/Build/$(image),$(1)))
@@ -288,6 +286,8 @@ $(eval $(call ImageDTB,CFEDTB,DVAG3810BN,DVAG3810BN,dva-g3810bn_tl,96358VW,6358)
 $(eval $(call ImageDTB,OLDCFEDTB,DV201AMR,DV-201AMR,dv-201amr,DV201AMR,6348))
 # Dynalink RTA1025W (numerous routers)
 $(eval $(call ImageDTB,CFEDTB,RTA1025W,RTA1025W_16,rta1025w,RTA1025W_16,6348,--layoutver 5))
 $(eval $(call ImageDTB,OLDCFEDTB,DV201AMR,DV-201AMR,dv-201amr,DV201AMR,6348))
 # Dynalink RTA1025W (numerous routers)
 $(eval $(call ImageDTB,CFEDTB,RTA1025W,RTA1025W_16,rta1025w,RTA1025W_16,6348,--layoutver 5))
+# Dynalink RTA1320 (numerous routers)
+$(eval $(call ImageDTB,CFEDTB,RTA1320,RTA1320_16M,rta1320,RTA1320_16M,6338,--layoutver 5))
 # Huawei HG520v
 $(eval $(call ImageDTB,CFEDTB,HG520v,HG520v,hg520v,HW6358GW_B,6358,--rsa-signature "EchoLife_HG520v"))
 # Huawei HG553
 # Huawei HG520v
 $(eval $(call ImageDTB,CFEDTB,HG520v,HG520v,hg520v,HW6358GW_B,6358,--rsa-signature "EchoLife_HG520v"))
 # Huawei HG553
index 2aa9b72..16cc061 100644 (file)
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
+@@ -1595,6 +1635,7 @@ static struct of_device_id const bcm963x
+ #ifdef CONFIG_BCM63XX_CPU_6338
+       { .compatible = "brcm,bcm96338gw", .data = &board_96338gw, },
+       { .compatible = "brcm,bcm96338w", .data = &board_96338w, },
++      { .compatible = "dynalink,rta1320", .data = &board_rta1320_16m, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6345
+       { .compatible = "brcm,bcm96345gw2", .data = &board_96345gw2, },
index 593ee24..0635ef7 100644 (file)
@@ -81,7 +81,7 @@
  #endif
  };
  
  #endif
  };
  
-@@ -1669,6 +1736,7 @@ static struct of_device_id const bcm963x
+@@ -1670,6 +1737,7 @@ static struct of_device_id const bcm963x
        { .compatible = "pirelli,agpf-s0", .data = &board_AGPFS0, },
        { .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
        { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
        { .compatible = "pirelli,agpf-s0", .data = &board_AGPFS0, },
        { .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
        { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
index ef0faae..e8d7afd 100644 (file)
@@ -74,7 +74,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1771,6 +1831,22 @@ void __init board_bcm963xx_init(void)
+@@ -1772,6 +1832,22 @@ void __init board_bcm963xx_init(void)
                val &= MPI_CSBASE_BASE_MASK;
        }
        boot_addr = (u8 *)KSEG1ADDR(val);
                val &= MPI_CSBASE_BASE_MASK;
        }
        boot_addr = (u8 *)KSEG1ADDR(val);
index bd3fbb4..3faf0b6 100644 (file)
@@ -67,7 +67,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1831,6 +1884,8 @@ static struct of_device_id const bcm963x
+@@ -1832,6 +1885,8 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
        { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
        { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
        { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
index 3bc4cdf..cb1d857 100644 (file)
@@ -85,7 +85,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1888,6 +1959,7 @@ static struct of_device_id const bcm963x
+@@ -1889,6 +1960,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
        { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
        { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
        { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
index d1ac860..bf1686f 100644 (file)
@@ -107,7 +107,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
-@@ -2025,6 +2108,7 @@ static struct of_device_id const bcm963x
+@@ -2026,6 +2109,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index eef58c7..89e6d98 100644 (file)
@@ -90,7 +90,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif
  };
  
  #endif
  };
  
-@@ -2108,6 +2175,7 @@ static struct of_device_id const bcm963x
+@@ -2109,6 +2176,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index a5642cb..f8ee450 100644 (file)
        &board_HW553,
        &board_spw303v,
  #endif
        &board_HW553,
        &board_spw303v,
  #endif
-@@ -2427,6 +2552,7 @@ static struct of_device_id const bcm963x
+@@ -2428,6 +2553,7 @@ static struct of_device_id const bcm963x
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
index 6ff557a..703b2ea 100644 (file)
@@ -82,7 +82,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -2555,6 +2623,7 @@ static struct of_device_id const bcm963x
+@@ -2556,6 +2624,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
index 2a5e6b6..61b1f3d 100644 (file)
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
-@@ -2634,6 +2739,9 @@ static struct of_device_id const bcm963x
+@@ -2635,6 +2740,9 @@ static struct of_device_id const bcm963x
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
index fcde5ac..1bb2131 100644 (file)
@@ -66,7 +66,7 @@
        &board_DV201AMR,
        &board_96348gw_a,
        &board_rta1025w_16,
        &board_DV201AMR,
        &board_96348gw_a,
        &board_rta1025w_16,
-@@ -2715,6 +2767,7 @@ static struct of_device_id const bcm963x
+@@ -2716,6 +2768,7 @@ static struct of_device_id const bcm963x
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
        { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
        { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
        { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
        { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
index 74d787f..e3c2eec 100644 (file)
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
-@@ -3160,6 +3560,9 @@ static struct of_device_id const bcm963x
+@@ -3161,6 +3561,9 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
index 8f5ebe5..eaf7c56 100644 (file)
@@ -111,7 +111,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -3746,6 +3837,7 @@ static struct of_device_id const bcm963x
+@@ -3747,6 +3838,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
index 0b4009e..32823e8 100644 (file)
@@ -68,7 +68,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -4277,6 +4323,7 @@ static struct of_device_id const bcm963x
+@@ -4278,6 +4324,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96345gw2", .data = &board_96345gw2, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6348
        { .compatible = "brcm,bcm96345gw2", .data = &board_96345gw2, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6348
index d735296..8f84448 100644 (file)
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -4601,6 +4714,7 @@ static struct of_device_id const bcm963x
+@@ -4602,6 +4715,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index e512148..654ec6f 100644 (file)
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -4714,6 +4825,7 @@ static struct of_device_id const bcm963x
+@@ -4715,6 +4826,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index dabb788..dd9aa29 100644 (file)
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -4826,6 +4937,7 @@ static struct of_device_id const bcm963x
+@@ -4827,6 +4938,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index 6669877..c6f3d19 100644 (file)
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -4939,6 +5030,7 @@ static struct of_device_id const bcm963x
+@@ -4940,6 +5031,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 5dd9a8b..0fa25c3 100644 (file)
@@ -65,7 +65,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -5007,6 +5058,7 @@ static struct of_device_id const bcm963x
+@@ -5008,6 +5059,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index 2aa9b72..16cc061 100644 (file)
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
+@@ -1595,6 +1635,7 @@ static struct of_device_id const bcm963x
+ #ifdef CONFIG_BCM63XX_CPU_6338
+       { .compatible = "brcm,bcm96338gw", .data = &board_96338gw, },
+       { .compatible = "brcm,bcm96338w", .data = &board_96338w, },
++      { .compatible = "dynalink,rta1320", .data = &board_rta1320_16m, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6345
+       { .compatible = "brcm,bcm96345gw2", .data = &board_96345gw2, },
index 593ee24..0635ef7 100644 (file)
@@ -81,7 +81,7 @@
  #endif
  };
  
  #endif
  };
  
-@@ -1669,6 +1736,7 @@ static struct of_device_id const bcm963x
+@@ -1670,6 +1737,7 @@ static struct of_device_id const bcm963x
        { .compatible = "pirelli,agpf-s0", .data = &board_AGPFS0, },
        { .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
        { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
        { .compatible = "pirelli,agpf-s0", .data = &board_AGPFS0, },
        { .compatible = "sfr,nb4-ser-r0", .data = &board_nb4_ser_r0, },
        { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
index ef0faae..e8d7afd 100644 (file)
@@ -74,7 +74,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1771,6 +1831,22 @@ void __init board_bcm963xx_init(void)
+@@ -1772,6 +1832,22 @@ void __init board_bcm963xx_init(void)
                val &= MPI_CSBASE_BASE_MASK;
        }
        boot_addr = (u8 *)KSEG1ADDR(val);
                val &= MPI_CSBASE_BASE_MASK;
        }
        boot_addr = (u8 *)KSEG1ADDR(val);
index bd3fbb4..3faf0b6 100644 (file)
@@ -67,7 +67,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1831,6 +1884,8 @@ static struct of_device_id const bcm963x
+@@ -1832,6 +1885,8 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
        { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
        { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
        { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
index 3bc4cdf..cb1d857 100644 (file)
@@ -85,7 +85,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1888,6 +1959,7 @@ static struct of_device_id const bcm963x
+@@ -1889,6 +1960,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
        { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
        { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
        { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
index d1ac860..bf1686f 100644 (file)
@@ -107,7 +107,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
-@@ -2025,6 +2108,7 @@ static struct of_device_id const bcm963x
+@@ -2026,6 +2109,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index eef58c7..89e6d98 100644 (file)
@@ -90,7 +90,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif
  };
  
  #endif
  };
  
-@@ -2108,6 +2175,7 @@ static struct of_device_id const bcm963x
+@@ -2109,6 +2176,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index a5642cb..f8ee450 100644 (file)
        &board_HW553,
        &board_spw303v,
  #endif
        &board_HW553,
        &board_spw303v,
  #endif
-@@ -2427,6 +2552,7 @@ static struct of_device_id const bcm963x
+@@ -2428,6 +2553,7 @@ static struct of_device_id const bcm963x
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
index 6ff557a..703b2ea 100644 (file)
@@ -82,7 +82,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -2555,6 +2623,7 @@ static struct of_device_id const bcm963x
+@@ -2556,6 +2624,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
index 2a5e6b6..61b1f3d 100644 (file)
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
-@@ -2634,6 +2739,9 @@ static struct of_device_id const bcm963x
+@@ -2635,6 +2740,9 @@ static struct of_device_id const bcm963x
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
index fcde5ac..1bb2131 100644 (file)
@@ -66,7 +66,7 @@
        &board_DV201AMR,
        &board_96348gw_a,
        &board_rta1025w_16,
        &board_DV201AMR,
        &board_96348gw_a,
        &board_rta1025w_16,
-@@ -2715,6 +2767,7 @@ static struct of_device_id const bcm963x
+@@ -2716,6 +2768,7 @@ static struct of_device_id const bcm963x
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
        { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
        { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
        { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
        { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
index 74d787f..e3c2eec 100644 (file)
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
-@@ -3160,6 +3560,9 @@ static struct of_device_id const bcm963x
+@@ -3161,6 +3561,9 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
index 8f5ebe5..eaf7c56 100644 (file)
@@ -111,7 +111,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -3746,6 +3837,7 @@ static struct of_device_id const bcm963x
+@@ -3747,6 +3838,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
index 0b4009e..32823e8 100644 (file)
@@ -68,7 +68,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -4277,6 +4323,7 @@ static struct of_device_id const bcm963x
+@@ -4278,6 +4324,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96345gw2", .data = &board_96345gw2, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6348
        { .compatible = "brcm,bcm96345gw2", .data = &board_96345gw2, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6348
index d735296..8f84448 100644 (file)
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -4601,6 +4714,7 @@ static struct of_device_id const bcm963x
+@@ -4602,6 +4715,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index e512148..654ec6f 100644 (file)
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -4714,6 +4825,7 @@ static struct of_device_id const bcm963x
+@@ -4715,6 +4826,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index dabb788..dd9aa29 100644 (file)
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -4826,6 +4937,7 @@ static struct of_device_id const bcm963x
+@@ -4827,6 +4938,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index 6669877..c6f3d19 100644 (file)
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -4939,6 +5030,7 @@ static struct of_device_id const bcm963x
+@@ -4940,6 +5031,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 5dd9a8b..0fa25c3 100644 (file)
@@ -65,7 +65,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -5007,6 +5058,7 @@ static struct of_device_id const bcm963x
+@@ -5008,6 +5059,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index 9e36e9f..53f3f40 100644 (file)
@@ -13,3 +13,12 @@ define Profile/RTA1025W/Description
   Package set optimized for RTA1025W.
 endef
 $(eval $(call Profile,RTA1025W))
   Package set optimized for RTA1025W.
 endef
 $(eval $(call Profile,RTA1025W))
+
+define Profile/RTA1320
+  NAME:=Dynalink RTA1320
+  PACKAGES:=
+endef
+define Profile/RTA1320/Description
+  Package set optimized for RTA1320.
+endef
+$(eval $(call Profile,RTA1320))