* Fixed buildscripts
authorSteven Barth <steven@midlink.org>
Thu, 8 May 2008 16:46:00 +0000 (16:46 +0000)
committerSteven Barth <steven@midlink.org>
Thu, 8 May 2008 16:46:00 +0000 (16:46 +0000)
Makefile
build/module.mk

index a57acf4..473d031 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -16,7 +16,7 @@ clean:
 
 host: build
        mkdir -p host/ffluci
 
 host: build
        mkdir -p host/ffluci
-       for i in $(MODULES); do cp $$i/dist$(LUCI_INSTALLDIR) host/ffluci -R; done
+       for i in $(MODULES); do cp $$i/dist$(LUCI_INSTALLDIR) host/ -R 2>/dev/null || true; done
        
 hostclean:
        
 hostclean:
-       rm host -rf
\ No newline at end of file
+       rm host -rf
index 3db3cc3..52c0e52 100644 (file)
@@ -4,8 +4,8 @@ all: compile
 
 source:
        mkdir -p dist$(LUCI_INSTALLDIR)
 
 source:
        mkdir -p dist$(LUCI_INSTALLDIR)
-       [ -d root ] && cp root/* dist -R
-       [ -d src ] && cp src/* dist$(LUCI_INSTALLDIR) -R
+       cp root/* dist -R 2>/dev/null || true
+       cp src/* dist$(LUCI_INSTALLDIR) -R 2>/dev/null || true
        for i in $$(find dist -name .svn); do rm $$i -rf; done  
        
 compile: source
        for i in $$(find dist -name .svn); do rm $$i -rf; done  
        
 compile: source