* Fix builds
authorSteven Barth <steven@midlink.org>
Thu, 8 May 2008 16:37:47 +0000 (16:37 +0000)
committerSteven Barth <steven@midlink.org>
Thu, 8 May 2008 16:37:47 +0000 (16:37 +0000)
applications/luci-fw/src/model/cbi/admin_network/firewall.lua [deleted file]
applications/luci-fw/src/model/cbi/admin_network/portfw.lua [deleted file]
applications/luci-fw/src/model/menu/50luci-fw.lua [deleted file]
build/module.mk

diff --git a/applications/luci-fw/src/model/cbi/admin_network/firewall.lua b/applications/luci-fw/src/model/cbi/admin_network/firewall.lua
deleted file mode 100644 (file)
index 4ff15db..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
--- ToDo: Translate, Add descriptions and help texts
-m = Map("luci_fw", "Firewall", [[Mit Hilfe der Firewall können Zugriffe auf das Netzwerk
-erlaubt, verboten oder umgeleitet werden.]])
-
-s = m:section(TypedSection, "rule")
-s.addremove = true
-s.anonymous = true
-
-chain = s:option(ListValue, "chain", "Kette")
-chain:value("forward", "Forward")
-chain:value("input", "Input")
-chain:value("output", "Output")
-chain:value("prerouting", "Prerouting")
-chain:value("postrouting", "Postrouting")
-
-s:option(Value, "iface", "Eingangsschnittstelle").optional = true
-s:option(Value, "oface", "Ausgangsschnittstelle").optional = true
-
-proto = s:option(ListValue, "proto", "Protokoll")
-proto.optional = true
-proto:value("")
-proto:value("tcp", "TCP")
-proto:value("udp", "UDP")
-
-s:option(Value, "source", "Quelladresse").optional = true
-s:option(Value, "destination", "Zieladresse").optional = true
-s:option(Value, "mac", "MAC-Adresse").optional = true
-
-sport = s:option(Value, "sport", "Quellport")
-sport.optional = true
-sport:depends("proto", "tcp")
-sport:depends("proto", "udp")
-
-dport = s:option(Value, "dport", "Zielport")
-dport.optional = true
-dport:depends("proto", "tcp")
-dport:depends("proto", "udp")
-
-tosrc = s:option(Value, "tosrc", "Neue Quelladresse [SNAT]")
-tosrc.optional = true
-tosrc:depends("jump", "SNAT")
-
-tosrc = s:option(Value, "todest", "Neue Zieladresse [DNAT]")
-tosrc.optional = true
-tosrc:depends("jump", "DNAT")
-
-jump = s:option(ListValue, "jump", "Aktion")
-jump.rmempty = true
-jump:value("", "")
-jump:value("ACCEPT", "annehmen (ACCEPT)")
-jump:value("REJECT", "zurückweisen (REJECT)")
-jump:value("DROP", "verwerfen (DROP)")
-jump:value("LOG", "protokollieren (LOG)")
-jump:value("DNAT", "Ziel umschreiben (DNAT) [nur Prerouting]")
-jump:value("MASQUERADE", "maskieren (MASQUERADE) [nur Postrouting]")
-jump:value("SNAT", "Quelle umschreiben (SNAT) [nur Postrouting]")
-
-
-add = s:option(Value, "command", "Eigener Befehl")
-add.size = 50
-add.rmempty = true
-
-return m
diff --git a/applications/luci-fw/src/model/cbi/admin_network/portfw.lua b/applications/luci-fw/src/model/cbi/admin_network/portfw.lua
deleted file mode 100644 (file)
index 96822b5..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
--- ToDo: Translate, Add descriptions and help texts
-require("ffluci.sys")
-m = Map("luci_fw", "Portweiterleitung", [[Portweiterleitungen ermöglichen es interne
-Netzwerkdienste von einem anderen externen Netzwerk aus erreichbar zu machen.]])
-
-s = m:section(TypedSection, "portfw")
-s.addremove = true
-s.anonymous = true
-
-iface = s:option(ListValue, "iface", "Externes Interface")
-iface:value("")
-for k,v in pairs(ffluci.sys.net.devices()) do
-       iface:value(v)
-end
-
-proto = s:option(ListValue, "proto", "Protokoll")
-proto:value("tcp", "TCP")
-proto:value("udp", "UDP")
-proto:value("tcpudp", "TCP + UDP")
-
-dport = s:option(Value, "dport", "Externer Port", "Port[:Endport]")
-
-to = s:option(Value, "to", "Interne Adresse", "IP-Adresse[:Zielport[-Zielendport]]")
-
-return m
diff --git a/applications/luci-fw/src/model/menu/50luci-fw.lua b/applications/luci-fw/src/model/menu/50luci-fw.lua
deleted file mode 100644 (file)
index 93aba2f..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-sel("admin", "network")
-act("portfw", "Portweiterleitung")
-act("firewall", "Firewall")
\ No newline at end of file
index 45732a4..3db3cc3 100644 (file)
@@ -4,8 +4,8 @@ all: compile
 
 source:
        mkdir -p dist$(LUCI_INSTALLDIR)
 
 source:
        mkdir -p dist$(LUCI_INSTALLDIR)
-       cp root/* dist -R
-       cp src/* dist$(LUCI_INSTALLDIR) -R
+       [ -d root ] && cp root/* dist -R
+       [ -d src ] && cp src/* dist$(LUCI_INSTALLDIR) -R
        for i in $$(find dist -name .svn); do rm $$i -rf; done  
        
 compile: source
        for i in $$(find dist -name .svn); do rm $$i -rf; done  
        
 compile: source