make the openwrt package dir install the shared includes into the staging dir
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 May 2005 20:50:17 +0000 (20:50 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 May 2005 20:50:17 +0000 (20:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1117 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/openwrt/Makefile

index 850c872..71edbee 100644 (file)
@@ -67,6 +67,8 @@ $(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
 source: $(DL_DIR)/$(LINKSYS_WLCONF_TGZ)
 prepare: $(LINKSYS_WLCONF_DIR)/.unpacked
 compile: prepare libnvram-compile libshared-compile $(PKG_IPK) $(PKG_WLCOMPAT)
+       mkdir -p $(STAGING_DIR)/usr/include
+       cp -a ./include/* $(STAGING_DIR)/usr/include/
 install: libnvram-install libshared-install \
         $(TARGET_DIR)/usr/sbin/wlconf \
         $(IPKG_STATE_DIR)/info/$(PKG_NAME).list \