kexec-tools: reduce size
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jun 2013 11:27:16 +0000 (11:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jun 2013 11:27:16 +0000 (11:27 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37072 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/boot/kexec-tools/Makefile
package/boot/kexec-tools/patches/100-reduce_size.patch [new file with mode: 0644]

index 541dca2..40ba9eb 100644 (file)
@@ -56,6 +56,9 @@ CONFIGURE_ARGS = \
                --sysconfdir=/etc \
                $(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib
 
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
 CONFIGURE_VARS += \
        BUILD_CC="$(HOSTCC)" \
        TARGET_CC="$(TARGET_CC)"
diff --git a/package/boot/kexec-tools/patches/100-reduce_size.patch b/package/boot/kexec-tools/patches/100-reduce_size.patch
new file mode 100644 (file)
index 0000000..eafca7b
--- /dev/null
@@ -0,0 +1,36 @@
+--- a/kexec/crashdump-xen.c
++++ b/kexec/crashdump-xen.c
+@@ -111,6 +111,7 @@ static int xen_detect_pv_guest(void)
+  * This includes dom0, which is the only PV guest where kexec/kdump works.
+  * HVM guests have to be handled as native hardware.
+  */
++#if defined(__i386__) || defined(__x86_64__)
+ int xen_present(void)
+ {
+       if (!is_dom0) {
+@@ -121,6 +122,7 @@ int xen_present(void)
+       }
+       return is_dom0 > 0;
+ }
++#endif
+ unsigned long xen_architecture(struct crash_elf_info *elf_info)
+ {
+--- a/kexec/crashdump.h
++++ b/kexec/crashdump.h
+@@ -56,7 +56,15 @@ unsigned long crash_architecture(struct 
+ unsigned long phys_to_virt(struct crash_elf_info *elf_info,
+                          unsigned long paddr);
++#if defined(__i386__) || defined(__x86_64__)
+ int xen_present(void);
++#else
++static inline int xen_present(void)
++{
++      return 0;
++}
++#endif
++
+ unsigned long xen_architecture(struct crash_elf_info *elf_info);
+ int xen_get_nr_phys_cpus(void);
+ int xen_get_note(int cpu, uint64_t *addr, uint64_t *len);