kexec-tools: make zlib support optional, but enabled by default
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jun 2013 11:27:13 +0000 (11:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jun 2013 11:27:13 +0000 (11:27 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37071 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/boot/kexec-tools/Config.in
package/boot/kexec-tools/Makefile

index 60c819d..2642171 100644 (file)
@@ -18,4 +18,9 @@ config KEXEC_TOOLS_kdump
        help
          Include the kdump utility.
 
+config KEXEC_ZLIB
+       bool
+       prompt "zlib support"
+       default y
+
 endmenu
index fa4f4d8..541dca2 100644 (file)
@@ -17,12 +17,14 @@ PKG_MD5SUM:=b3ced2097ce3981abba38ceedc84f939
 
 PKG_FIXUP:=autoreconf
 
+PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/kexec-tools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@armeb||@arm||@i386||@powerpc64||@mipsel||@mips +zlib
+  DEPENDS:=@armeb||@arm||@i386||@powerpc64||@mipsel||@mips +KEXEC_ZLIB:zlib
   TITLE:=Kernel boots kernel
   URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
   MAINTAINER:=Florian Fainelli <florian@openwrt.org>
@@ -51,7 +53,8 @@ CONFIGURE_ARGS = \
                --bindir=/usr/bin \
                --sbindir=/usr/sbin \
                --libexecdir=/usr/lib \
-               --sysconfdir=/etc
+               --sysconfdir=/etc \
+               $(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib
 
 CONFIGURE_VARS += \
        BUILD_CC="$(HOSTCC)" \