6in4: don't use /dev/stdout for wget calls
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Feb 2015 13:33:15 +0000 (13:33 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Feb 2015 13:33:15 +0000 (13:33 +0000)
Busybox ash does not implement /dev/stdout, therfore any wget output
is written into a file /dev/stdout instead of onto the standard output.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44301 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/6in4/Makefile
package/network/ipv6/6in4/files/6in4.sh

index aeb187c..0dc1068 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2014 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=18
+PKG_VERSION:=19
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
index f639a5d..00b6e35 100755 (executable)
@@ -1,6 +1,6 @@
 #!/bin/sh
 # 6in4.sh - IPv6-in-IPv4 tunnel backend
-# Copyright (c) 2010-2014 OpenWrt.org
+# Copyright (c) 2010-2015 OpenWrt.org
 
 [ -n "$INCLUDE_ONLY" ] || {
        . /lib/functions.sh
@@ -68,7 +68,7 @@ proto_6in4_setup() {
 
                local http="http"
                local urlget="wget"
-               local urlget_opts="-qO/dev/stdout"
+               local urlget_opts="-qO-"
                local ca_path="${SSL_CERT_DIR-/etc/ssl/certs}"
 
                if [ -n "$(which curl)" ]; then
@@ -82,7 +82,7 @@ proto_6in4_setup() {
                if [ "$http" = "http" ] &&
                        wget --version 2>&1 | grep -qF "+https"; then
                        urlget="wget"
-                       urlget_opts="-qO/dev/stdout --ca-directory=$ca_path"
+                       urlget_opts="-qO- --ca-directory=$ca_path"
                        http="https"
                fi
                [ "$http" = "https" -a -z "$(find $ca_path -name "*.0" 2>/dev/null)" ] && {