build: accept apple llvm as fallback for gcc/g++
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Feb 2015 10:07:31 +0000 (10:07 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Feb 2015 10:07:31 +0000 (10:07 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44298 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk
include/prereq.mk

index 926a06f..3f8f987 100644 (file)
@@ -31,7 +31,8 @@ $(eval $(call SetupHostCommand,gcc, \
        gcc49 --version | grep gcc, \
        gcc48 --version | grep gcc, \
        gcc47 --version | grep gcc, \
-       gcc46 --version | grep gcc))
+       gcc46 --version | grep gcc, \
+       gcc --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-gcc, \
        Please reinstall the GNU C Compiler - it appears to be broken, \
@@ -45,7 +46,8 @@ $(eval $(call SetupHostCommand,g++, \
        g++49 --version | grep g++, \
        g++48 --version | grep g++, \
        g++47 --version | grep g++, \
-       g++46 --version | grep g++))
+       g++46 --version | grep g++, \
+       g++ --version | grep Apple.LLVM ))
 
 $(eval $(call TestHostCommand,working-g++, \
        Please reinstall the GNU C++ Compiler - it appears to be broken, \
index 9bc5e0d..71ca96e 100644 (file)
@@ -88,7 +88,8 @@ define SetupHostCommand
   define Require/$(1)
        for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
                   $(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
-                  $(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)); do \
+                  $(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \
+                          $(call QuoteHostCommand,$(9)); do \
                if [ -n "$$$$$$$$cmd" ]; then \
                        bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
                                which "$$$$$$$${cmd%% *}")"; \