[busybox] make init and logread depend on !PROCD_INIT
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Mar 2013 18:11:31 +0000 (18:11 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Mar 2013 18:11:31 +0000 (18:11 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36005 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Makefile
package/busybox/config/init/Config.in
package/busybox/config/sysklogd/Config.in

index 7aaaf6c..f4553c0 100644 (file)
@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
 PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
 
+PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
 PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
 PKG_BUILD_PARALLEL:=1
 
@@ -112,6 +113,7 @@ define Package/busybox/install
                $(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
        done
        -rm -rf $(1)/lib64
+       $(if $(CONFIG_PROCD_INIT),rm -f $(1)/sbin/init $(1)/sbin/logread)
 endef
 
 $(eval $(call BuildPackage,busybox))
index 61c2014..4b3c8dd 100644 (file)
@@ -73,6 +73,7 @@ config BUSYBOX_CONFIG_INIT
        bool "init"
        default y
        select BUSYBOX_CONFIG_FEATURE_SYSLOG
+       depends on !PROCD_INIT
        help
          init is the first program run when the system boots.
 
index 20e1aff..087a5b4 100644 (file)
@@ -96,7 +96,7 @@ config BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG_BUFFER_SIZE
 config BUSYBOX_CONFIG_LOGREAD
        bool "logread"
        default y
-       depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG
+       depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG && !PROCD_INIT
        help
          If you enabled Circular Buffer support, you almost
          certainly want to enable this feature as well. This