[hostapd] use new button scheme
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Mar 2013 18:11:25 +0000 (18:11 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Mar 2013 18:11:25 +0000 (18:11 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36004 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/hostapd/Makefile
package/network/services/hostapd/files/wps-hotplug.sh

index 80845bf..16db2d8 100644 (file)
@@ -303,6 +303,11 @@ ifneq ($(LOCAL_TYPE),supplicant)
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/hotplug.d/button
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
        $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
+       $(if $(CONFIG_PROCD_INIT),
+               $(INSTALL_DIR) $(1)/etc/rc.button/
+               $(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps,
+               $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
+       )
   endef
 endif
 
index b5376cc..ffd3cf9 100644 (file)
@@ -1,3 +1,5 @@
+#!/bin/sh
+
 if [ "$ACTION" = "pressed" -a "$BUTTON" = "wps" ]; then
        for dir in /var/run/hostapd-*; do
                [ -d "$dir" ] || continue