kernel: update linux 3.8 to 3.8.9
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Apr 2013 16:55:42 +0000 (16:55 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Apr 2013 16:55:42 +0000 (16:55 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36453 3c298f89-4303-0410-b956-a3cf2f4a3e73

37 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.8/902-unaligned_access_hacks.patch
target/linux/at91/Makefile
target/linux/at91/patches/700-tqma9263-support.patch
target/linux/at91/patches/805-free_some_portc_pins.patch
target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/patches-3.8/030-mtd-bcm47xxsflash-add-own-struct-for-abstrating-bus-.patch
target/linux/brcm47xx/patches-3.8/060-ssb-add-serial-flash-driver.patch
target/linux/brcm47xx/patches-3.8/070-bcma-add-functions-to-write-to-serial-flash.patch
target/linux/brcm47xx/patches-3.8/700-ssb-gigabit-ethernet-driver.patch
target/linux/brcm47xx/patches-3.8/750-bgmac.patch
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/ep93xx/Makefile
target/linux/generic/patches-3.8/020-ssb_update.patch
target/linux/generic/patches-3.8/025-bcma_backport.patch
target/linux/generic/patches-3.8/950-vm_exports.patch
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/generic/target.mk
target/linux/xburst/Makefile

index 2eb73ce..9bcbd0b 100644 (file)
@@ -11,8 +11,8 @@ endif
 ifeq ($(LINUX_VERSION),3.7.10)
   LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
 endif
-ifeq ($(LINUX_VERSION),3.8.8)
-  LINUX_KERNEL_MD5SUM:=3b4feff68460881a5dde1307fe1ce87f
+ifeq ($(LINUX_VERSION),3.8.9)
+  LINUX_KERNEL_MD5SUM:=b5286ad3d8a729e9ae48b26211e05aec
 endif
 
 # disable the md5sum check for unknown kernel versions
index 3910a85..ac33719 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index fa698a4..7e24715 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index ae778da..8c2a182 100644 (file)
  #include <asm/uaccess.h>
  
  #include <linux/proc_fs.h>
-@@ -763,10 +764,10 @@ static void tcp_v6_send_response(struct 
+@@ -763,10 +764,10 @@ static void tcp_v6_send_response(struct
        topt = (__be32 *)(t1 + 1);
  
        if (ts) {
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
                fl6.flowi6_mark = skb->mark;
  
-@@ -1240,7 +1240,7 @@ static int ip6gre_header(struct sk_buff 
+@@ -1240,7 +1240,7 @@ static int ip6gre_header(struct sk_buff
        struct ipv6hdr *ipv6h = (struct ipv6hdr *)skb_push(skb, t->hlen);
        __be16 *p = (__be16 *)(ipv6h+1);
  
  #include <linux/netdevice.h>
 --- a/include/net/inet_ecn.h
 +++ b/include/net/inet_ecn.h
-@@ -115,13 +115,13 @@ static inline int IP6_ECN_set_ce(struct 
+@@ -115,13 +115,13 @@ static inline int IP6_ECN_set_ce(struct
  {
        if (INET_ECN_is_not_ect(ipv6_get_dsfield(iph)))
                return 0;
        ptr = ip6hoff + sizeof(struct ipv6hdr);
 --- a/net/xfrm/xfrm_input.c
 +++ b/net/xfrm/xfrm_input.c
-@@ -77,8 +77,8 @@ int xfrm_parse_spi(struct sk_buff *skb, 
+@@ -77,8 +77,8 @@ int xfrm_parse_spi(struct sk_buff *skb,
        if (!pskb_may_pull(skb, hlen))
                return -EINVAL;
  
index 10b91cc..ea72b67 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
 FEATURES:=squashfs jffs2 targz ext2 usb
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 
-LINUX_VERSION:=3.8.7
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 321fe59..4db1ff8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-at91/Kconfig
 +++ b/arch/arm/mach-at91/Kconfig
-@@ -335,6 +335,12 @@ config MACH_NEOCORE926
+@@ -358,6 +358,12 @@ config MACH_NEOCORE926
        help
          Select this if you are using the Adeneo Neocore 926 board.
  
@@ -15,7 +15,7 @@
  # ----------------------------------------------------------
 --- a/arch/arm/mach-at91/Makefile
 +++ b/arch/arm/mach-at91/Makefile
-@@ -58,6 +58,7 @@ obj-$(CONFIG_MACH_AT91SAM9G10EK) += boar
+@@ -67,6 +67,7 @@ obj-$(CONFIG_MACH_AT91SAM9G10EK) += boar
  obj-$(CONFIG_MACH_AT91SAM9263EK) += board-sam9263ek.o
  obj-$(CONFIG_MACH_USB_A9263)  += board-usb-a926x.o
  obj-$(CONFIG_MACH_NEOCORE926) += board-neocore926.o
index df8e50a..a9694d1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-at91/at91sam9260_devices.c
 +++ b/arch/arm/mach-at91/at91sam9260_devices.c
-@@ -579,7 +579,7 @@ static struct platform_device at91sam926
+@@ -507,7 +507,7 @@ static struct platform_device at91sam926
        .num_resources  = ARRAY_SIZE(spi1_resources),
  };
  
index 59f9bb3..a97850a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-at91/board-flexibity.c
 +++ b/arch/arm/mach-at91/board-flexibity.c
-@@ -94,49 +94,49 @@ static struct gpio_led flexibity_leds[]
+@@ -89,49 +89,49 @@ static struct gpio_led flexibity_leds[]
                .name                   = "usb1:green",
                .gpio                   = AT91_PIN_PA12,
                .active_low             = 1,
index 2b77032..4caff66 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 7896202..b4d2b04 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 30bdbb2..1f3eea8 100644 (file)
 +#endif /* BCM47XXSFLASH */
 --- a/include/linux/bcma/bcma_driver_chipcommon.h
 +++ b/include/linux/bcma/bcma_driver_chipcommon.h
-@@ -528,6 +528,7 @@ struct bcma_sflash {
+@@ -529,6 +529,7 @@ struct bcma_sflash {
        u32 size;
  
        struct mtd_info *mtd;
index 9a9c194..6c17fb9 100644 (file)
  #define SSB_CHIPCO_BCAST_ADDR         0x0050
  #define SSB_CHIPCO_BCAST_DATA         0x0054
  #define SSB_CHIPCO_GPIOPULLUP         0x0058          /* Rev >= 20 only */
-@@ -503,7 +516,7 @@
+@@ -504,7 +517,7 @@
  #define SSB_CHIPCO_FLASHCTL_ST_PP     0x0302          /* Page Program */
  #define SSB_CHIPCO_FLASHCTL_ST_SE     0x02D8          /* Sector Erase */
  #define SSB_CHIPCO_FLASHCTL_ST_BE     0x00C7          /* Bulk Erase */
  #define SSB_CHIPCO_FLASHCTL_ST_RES    0x03AB          /* Read Electronic Signature */
  #define SSB_CHIPCO_FLASHCTL_ST_CSA    0x1000          /* Keep chip select asserted */
  #define SSB_CHIPCO_FLASHCTL_ST_SSE    0x0220          /* Sub-sector Erase */
-@@ -594,6 +607,9 @@ struct ssb_chipcommon {
+@@ -595,6 +608,9 @@ struct ssb_chipcommon {
        struct ssb_chipcommon_pmu pmu;
        u32 ticks_per_ms;
        u32 max_timer_ms;
index 934443d..0bd23cc 100644 (file)
  
  /** ChipCommon core registers. **/
  #define BCMA_CC_ID                    0x0000
-@@ -519,19 +520,6 @@ struct bcma_pflash {
+@@ -520,19 +521,6 @@ struct bcma_pflash {
        u32 window_size;
  };
  
  #ifdef CONFIG_BCMA_NFLASH
  struct mtd_info;
  
-@@ -565,7 +553,7 @@ struct bcma_drv_cc {
+@@ -566,7 +554,7 @@ struct bcma_drv_cc {
  #ifdef CONFIG_BCMA_DRIVER_MIPS
        struct bcma_pflash pflash;
  #ifdef CONFIG_BCMA_SFLASH
index e38f455..cdbae5f 100644 (file)
@@ -16,7 +16,7 @@
        {PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, PCI_DEVICE_ID_TIGON3_5751)},
        {PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, PCI_DEVICE_ID_TIGON3_5751M)},
        {PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, PCI_DEVICE_ID_TIGON3_5751F),
-@@ -570,7 +572,9 @@ static void _tw32_flush(struct tg3 *tp,
+@@ -571,7 +573,9 @@ static void _tw32_flush(struct tg3 *tp,
  static inline void tw32_mailbox_flush(struct tg3 *tp, u32 off, u32 val)
  {
        tp->write32_mbox(tp, off, val);
@@ -27,7 +27,7 @@
                tp->read32_mbox(tp, off);
  }
  
-@@ -580,7 +584,8 @@ static void tg3_write32_tx_mbox(struct t
+@@ -581,7 +585,8 @@ static void tg3_write32_tx_mbox(struct t
        writel(val, mbox);
        if (tg3_flag(tp, TXD_MBOX_HWBUG))
                writel(val, mbox);
@@ -37,7 +37,7 @@
                readl(mbox);
  }
  
-@@ -1088,7 +1093,8 @@ static void tg3_switch_clocks(struct tg3
+@@ -1089,7 +1094,8 @@ static void tg3_switch_clocks(struct tg3
  
  #define PHY_BUSY_LOOPS        5000
  
@@ -47,7 +47,7 @@
  {
        u32 frame_val;
        unsigned int loops;
-@@ -1104,7 +1110,7 @@ static int tg3_readphy(struct tg3 *tp, i
+@@ -1105,7 +1111,7 @@ static int tg3_readphy(struct tg3 *tp, i
  
        *val = 0x0;
  
@@ -56,7 +56,7 @@
                      MI_COM_PHY_ADDR_MASK);
        frame_val |= ((reg << MI_COM_REG_ADDR_SHIFT) &
                      MI_COM_REG_ADDR_MASK);
-@@ -1141,7 +1147,13 @@ static int tg3_readphy(struct tg3 *tp, i
+@@ -1142,7 +1148,13 @@ static int tg3_readphy(struct tg3 *tp, i
        return ret;
  }
  
@@ -71,7 +71,7 @@
  {
        u32 frame_val;
        unsigned int loops;
-@@ -1159,7 +1171,7 @@ static int tg3_writephy(struct tg3 *tp,
+@@ -1160,7 +1172,7 @@ static int tg3_writephy(struct tg3 *tp,
  
        tg3_ape_lock(tp, tp->phy_ape_lock);
  
@@ -80,7 +80,7 @@
                      MI_COM_PHY_ADDR_MASK);
        frame_val |= ((reg << MI_COM_REG_ADDR_SHIFT) &
                      MI_COM_REG_ADDR_MASK);
-@@ -1194,6 +1206,11 @@ static int tg3_writephy(struct tg3 *tp,
+@@ -1195,6 +1207,11 @@ static int tg3_writephy(struct tg3 *tp,
        return ret;
  }
  
@@ -92,7 +92,7 @@
  static int tg3_phy_cl45_write(struct tg3 *tp, u32 devad, u32 addr, u32 val)
  {
        int err;
-@@ -1778,6 +1795,11 @@ static int tg3_poll_fw(struct tg3 *tp)
+@@ -1779,6 +1796,11 @@ static int tg3_poll_fw(struct tg3 *tp)
        int i;
        u32 val;
  
        if (GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5906) {
                /* Wait up to 20ms for init done. */
                for (i = 0; i < 200; i++) {
-@@ -3443,6 +3465,13 @@ static int tg3_halt_cpu(struct tg3 *tp,
+@@ -3444,6 +3466,13 @@ static int tg3_halt_cpu(struct tg3 *tp,
                tw32_f(offset + CPU_MODE,  CPU_MODE_HALT);
                udelay(10);
        } else {
                for (i = 0; i < 10000; i++) {
                        tw32(offset + CPU_STATE, 0xffffffff);
                        tw32(offset + CPU_MODE,  CPU_MODE_HALT);
-@@ -3910,8 +3939,9 @@ static int tg3_power_down_prepare(struct
+@@ -3911,8 +3940,9 @@ static int tg3_power_down_prepare(struct
        tg3_frob_aux_power(tp, true);
  
        /* Workaround for unstable PLL clock */
                u32 val = tr32(0x7d00);
  
                val &= ~((1 << 16) | (1 << 4) | (1 << 2) | (1 << 1) | 1);
-@@ -4439,6 +4469,15 @@ relink:
+@@ -4440,6 +4470,15 @@ relink:
        if (current_link_up == 0 || (tp->phy_flags & TG3_PHYFLG_IS_LOW_POWER)) {
                tg3_phy_copper_begin(tp);
  
                tg3_readphy(tp, MII_BMSR, &bmsr);
                if ((!tg3_readphy(tp, MII_BMSR, &bmsr) && (bmsr & BMSR_LSTATUS)) ||
                    (tp->mac_mode & MAC_MODE_PORT_INT_LPBACK))
-@@ -4457,6 +4496,26 @@ relink:
+@@ -4458,6 +4497,26 @@ relink:
        else
                tp->mac_mode |= MAC_MODE_PORT_MODE_GMII;
  
        tp->mac_mode &= ~MAC_MODE_HALF_DUPLEX;
        if (tp->link_config.active_duplex == DUPLEX_HALF)
                tp->mac_mode |= MAC_MODE_HALF_DUPLEX;
-@@ -8435,6 +8494,16 @@ static int tg3_chip_reset(struct tg3 *tp
+@@ -8436,6 +8495,16 @@ static int tg3_chip_reset(struct tg3 *tp
                tw32(0x5000, 0x400);
        }
  
        tw32(GRC_MODE, tp->grc_mode);
  
        if (tp->pci_chip_rev_id == CHIPREV_ID_5705_A0) {
-@@ -10068,6 +10137,11 @@ static void tg3_timer(unsigned long __op
+@@ -10084,6 +10153,11 @@ static void tg3_timer(unsigned long __op
            tg3_flag(tp, 57765_CLASS))
                tg3_chk_missed_msi(tp);
  
        if (!tg3_flag(tp, TAGGED_STATUS)) {
                /* All of this garbage is because when using non-tagged
                 * IRQ status the mailbox/status_block protocol the chip
-@@ -12941,7 +13015,8 @@ static int tg3_ioctl(struct net_device *
+@@ -12957,7 +13031,8 @@ static int tg3_ioctl(struct net_device *
                        return -EAGAIN;
  
                spin_lock_bh(&tp->lock);
                spin_unlock_bh(&tp->lock);
  
                data->val_out = mii_regval;
-@@ -12957,7 +13032,8 @@ static int tg3_ioctl(struct net_device *
+@@ -12973,7 +13048,8 @@ static int tg3_ioctl(struct net_device *
                        return -EAGAIN;
  
                spin_lock_bh(&tp->lock);
                spin_unlock_bh(&tp->lock);
  
                return err;
-@@ -13810,6 +13886,14 @@ static void tg3_get_5720_nvram_info(stru
+@@ -13826,6 +13902,14 @@ static void tg3_get_5720_nvram_info(stru
  /* Chips other than 5700/5701 use the NVRAM for fetching info. */
  static void tg3_nvram_init(struct tg3 *tp)
  {
        tw32_f(GRC_EEPROM_ADDR,
             (EEPROM_ADDR_FSM_RESET |
              (EEPROM_DEFAULT_CLOCK_PERIOD <<
-@@ -14302,10 +14386,19 @@ static int tg3_phy_probe(struct tg3 *tp)
+@@ -14318,10 +14402,19 @@ static int tg3_phy_probe(struct tg3 *tp)
                         * subsys device table.
                         */
                        p = tg3_lookup_by_subsys(tp);
                        if (!tp->phy_id ||
                            tp->phy_id == TG3_PHY_ID_BCM8002)
                                tp->phy_flags |= TG3_PHYFLG_PHY_SERDES;
-@@ -15353,6 +15446,11 @@ static int tg3_get_invariants(struct tg3
+@@ -15369,6 +15462,11 @@ static int tg3_get_invariants(struct tg3
                }
        }
  
        /* Get eeprom hw config before calling tg3_set_power_state().
         * In particular, the TG3_FLAG_IS_NIC flag must be
         * determined before calling tg3_set_power_state() so that
-@@ -15686,12 +15784,19 @@ static int tg3_get_device_address(struct
+@@ -15702,12 +15800,19 @@ static int tg3_get_device_address(struct
        struct net_device *dev = tp->dev;
        u32 hi, lo, mac_offset;
        int addr_ok = 0;
        mac_offset = 0x7c;
        if (GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5704 ||
            tg3_flag(tp, 5780_CLASS)) {
-@@ -16052,6 +16157,8 @@ static int tg3_test_dma(struct tg3 *tp)
+@@ -16068,6 +16173,8 @@ static int tg3_test_dma(struct tg3 *tp)
                        tp->dma_rwctrl |= 0x001b000f;
                }
        }
  
        if (GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5703 ||
            GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5704)
-@@ -16396,6 +16503,18 @@ static int tg3_init_one(struct pci_dev *
+@@ -16412,6 +16519,18 @@ static int tg3_init_one(struct pci_dev *
        else
                tp->msg_enable = TG3_DEF_MSG_ENABLE;
  
         * setting below.
 --- a/drivers/net/ethernet/broadcom/tg3.h
 +++ b/drivers/net/ethernet/broadcom/tg3.h
-@@ -3030,6 +3030,11 @@ enum TG3_FLAGS {
+@@ -3032,6 +3032,11 @@ enum TG3_FLAGS {
        TG3_FLAG_57765_PLUS,
        TG3_FLAG_57765_CLASS,
        TG3_FLAG_5717_PLUS,
index 7ca2750..1c31d4c 100644 (file)
@@ -43,7 +43,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/bcma/driver_chipcommon_pmu.c
 +++ b/drivers/bcma/driver_chipcommon_pmu.c
-@@ -264,7 +264,7 @@ static u32 bcma_pmu_pll_clock_bcm4706(st
+@@ -280,7 +280,7 @@ static u32 bcma_pmu_pll_clock_bcm4706(st
  }
  
  /* query bus clock frequency for PMU-enabled chipcommon */
@@ -52,7 +52,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  {
        struct bcma_bus *bus = cc->core->bus;
  
-@@ -293,6 +293,7 @@ static u32 bcma_pmu_get_bus_clock(struct
+@@ -309,6 +309,7 @@ static u32 bcma_pmu_get_bus_clock(struct
        }
        return BCMA_CC_PMU_HT_CLOCK;
  }
@@ -1969,7 +1969,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 +#endif /* _BGMAC_H */
 --- a/include/linux/bcma/bcma_driver_chipcommon.h
 +++ b/include/linux/bcma/bcma_driver_chipcommon.h
-@@ -623,4 +623,6 @@ extern void bcma_chipco_regctl_maskset(s
+@@ -626,4 +626,6 @@ extern void bcma_chipco_regctl_maskset(s
                                       u32 offset, u32 mask, u32 set);
  extern void bcma_pmu_spuravoid_pllupdate(struct bcma_drv_cc *cc, int spuravoid);
  
index 79d0c9a..52e4524 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index d851ba2..a5a90ff 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index c604ea8..87f6c44 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 80b8fcc..7257720 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 DEVICE_TYPE:=developerboard
 
index d3cc6f1..e4d6993 100644 (file)
 +}
 --- a/drivers/ssb/driver_gpio.c
 +++ b/drivers/ssb/driver_gpio.c
-@@ -74,6 +74,16 @@ static void ssb_gpio_chipco_free(struct 
+@@ -74,6 +74,16 @@ static void ssb_gpio_chipco_free(struct
        ssb_chipco_gpio_pullup(&bus->chipco, 1 << gpio, 0);
  }
  
  
  static inline u32 mips_read32(struct ssb_mipscore *mcore,
                              u16 offset)
-@@ -189,34 +209,43 @@ static void ssb_mips_serial_init(struct 
+@@ -189,34 +209,43 @@ static void ssb_mips_serial_init(struct
  static void ssb_mips_flash_detect(struct ssb_mipscore *mcore)
  {
        struct ssb_bus *bus = mcore->dev->bus;
  #endif /* CONFIG_SSB_DRIVER_MIPS */
  
  #endif /* LINUX_SSB_MIPSCORE_H_ */
---- a/drivers/net/wireless/b43/phy_n.c
-+++ b/drivers/net/wireless/b43/phy_n.c
-@@ -5165,7 +5165,8 @@ static void b43_nphy_pmu_spur_avoid(stru
- #endif
- #ifdef CONFIG_B43_SSB
-       case B43_BUS_SSB:
--              /* FIXME */
-+              ssb_pmu_spuravoid_pllupdate(&dev->dev->sdev->bus->chipco,
-+                                          avoid);
-               break;
- #endif
-       }
---- a/drivers/ssb/driver_chipcommon_pmu.c
-+++ b/drivers/ssb/driver_chipcommon_pmu.c
-@@ -675,3 +675,32 @@ u32 ssb_pmu_get_controlclock(struct ssb_
-               return 0;
-       }
- }
-+
-+void ssb_pmu_spuravoid_pllupdate(struct ssb_chipcommon *cc, int spuravoid)
-+{
-+      u32 pmu_ctl = 0;
-+
-+      switch (cc->dev->bus->chip_id) {
-+      case 0x4322:
-+              ssb_chipco_pll_write(cc, SSB_PMU1_PLLCTL0, 0x11100070);
-+              ssb_chipco_pll_write(cc, SSB_PMU1_PLLCTL1, 0x1014140a);
-+              ssb_chipco_pll_write(cc, SSB_PMU1_PLLCTL5, 0x88888854);
-+              if (spuravoid == 1)
-+                      ssb_chipco_pll_write(cc, SSB_PMU1_PLLCTL2, 0x05201828);
-+              else
-+                      ssb_chipco_pll_write(cc, SSB_PMU1_PLLCTL2, 0x05001828);
-+              pmu_ctl = SSB_CHIPCO_PMU_CTL_PLL_UPD;
-+              break;
-+      case 43222:
-+              /* TODO: BCM43222 requires updating PLLs too */
-+              return;
-+      default:
-+              ssb_printk(KERN_ERR PFX
-+                         "Unknown spuravoidance settings for chip 0x%04X, not changing PLL\n",
-+                         cc->dev->bus->chip_id);
-+              return;
-+      }
-+
-+      chipco_set32(cc, SSB_CHIPCO_PMU_CTL, pmu_ctl);
-+}
-+EXPORT_SYMBOL_GPL(ssb_pmu_spuravoid_pllupdate);
 --- a/drivers/ssb/pci.c
 +++ b/drivers/ssb/pci.c
 @@ -339,6 +339,21 @@ static s8 r123_extract_antgain(u8 sprom_
  }
  
  /* Revs 4 5 and 8 have partially shared layout */
---- a/include/linux/ssb/ssb_driver_chipcommon.h
-+++ b/include/linux/ssb/ssb_driver_chipcommon.h
-@@ -219,6 +219,7 @@
- #define SSB_CHIPCO_PMU_CTL                    0x0600 /* PMU control */
- #define  SSB_CHIPCO_PMU_CTL_ILP_DIV           0xFFFF0000 /* ILP div mask */
- #define  SSB_CHIPCO_PMU_CTL_ILP_DIV_SHIFT     16
-+#define  SSB_CHIPCO_PMU_CTL_PLL_UPD           0x00000400
- #define  SSB_CHIPCO_PMU_CTL_NOILPONW          0x00000200 /* No ILP on wait */
- #define  SSB_CHIPCO_PMU_CTL_HTREQEN           0x00000100 /* HT req enable */
- #define  SSB_CHIPCO_PMU_CTL_ALPREQEN          0x00000080 /* ALP req enable */
-@@ -667,5 +668,6 @@ enum ssb_pmu_ldo_volt_id {
- void ssb_pmu_set_ldo_voltage(struct ssb_chipcommon *cc,
-                            enum ssb_pmu_ldo_volt_id id, u32 voltage);
- void ssb_pmu_set_ldo_paref(struct ssb_chipcommon *cc, bool on);
-+void ssb_pmu_spuravoid_pllupdate(struct ssb_chipcommon *cc, int spuravoid);
- #endif /* LINUX_SSB_CHIPCO_H_ */
 --- a/include/linux/ssb/ssb_regs.h
 +++ b/include/linux/ssb/ssb_regs.h
 @@ -289,11 +289,11 @@
index bdb3a23..1cabd42 100644 (file)
                return cap_ptr;
  
        /* check if the capability pointer field exists */
-@@ -426,7 +429,7 @@ void bcma_core_pci_hostmode_init(struct 
+@@ -426,7 +429,7 @@ void bcma_core_pci_hostmode_init(struct
        /* Reset RC */
        usleep_range(3000, 5000);
        pcicore_write32(pc, BCMA_CORE_PCI_CTL, BCMA_CORE_PCI_CTL_RST_OE);
        pcicore_write32(pc, BCMA_CORE_PCI_CTL, BCMA_CORE_PCI_CTL_RST |
                        BCMA_CORE_PCI_CTL_RST_OE);
  
-@@ -488,6 +491,17 @@ void bcma_core_pci_hostmode_init(struct 
+@@ -488,6 +491,17 @@ void bcma_core_pci_hostmode_init(struct
  
        bcma_core_pci_enable_crs(pc);
  
        pci_write_config_byte(dev, PCI_INTERRUPT_LINE, dev->irq);
  
        return 0;
-@@ -595,6 +609,6 @@ int bcma_core_pci_pcibios_map_irq(const 
+@@ -595,6 +609,6 @@ int bcma_core_pci_pcibios_map_irq(const
  
        pc_host = container_of(dev->bus->ops, struct bcma_drv_pci_host,
                               pci_ops);
index 9c15a1b..d94d556 100644 (file)
@@ -52,7 +52,7 @@
   * When we die, we re-parent all our children, and try to:
 --- a/kernel/sched/core.c
 +++ b/kernel/sched/core.c
-@@ -3634,6 +3634,7 @@ int can_nice(const struct task_struct *p
+@@ -3636,6 +3636,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
                capable(CAP_SYS_NICE));
  }
index e042ca4..88f12b1 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index 6161443..8db4e90 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 DEVICE_TYPE:=developerboard
 
index e06ff6a..7493441 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index fa30ecf..bb6f698 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 9e5109e..cb38d01 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 4c49e27..fcb604a 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 27e1a14..ab79d7c 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 9612e90..0a5533c 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 43520ab..1b359ad 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 2708308..56b2d20 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 801b3fd..cc6d977 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 DEVICE_TYPE:=developerboard
 
index 650a0be..3be431a 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 06605fc..534ffa3 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index 31dfa51..4e5f373 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME:=Generic
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 define Target/Description
        Build firmware images for x86 based boards
index 8b6dd1c..074f054 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio broken
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.8.8
+LINUX_VERSION:=3.8.9
 
 DEVICE_TYPE=other