lldp: remove calls to user/group_add/exists
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Sep 2014 12:28:22 +0000 (12:28 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Sep 2014 12:28:22 +0000 (12:28 +0000)
use the new ipkg based mechanism

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42472 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/lldpd/Makefile
package/network/services/lldpd/files/lldpd.init

index 3136783..0b85848 100644 (file)
@@ -31,6 +31,7 @@ define Package/lldpd
   TITLE:=Link Layer Discovery Protocol daemon
   URL:=https://github.com/vincentbernat/lldpd/wiki
   DEPENDS:=+libevent2 +USE_EGLIBC:libbsd
+  USERID:=lldp:lldp
 endef
 
 define Package/lldpd/description
index 3599950..b2eea70 100644 (file)
@@ -50,9 +50,6 @@ start() {
        [ $enable_sonmp -gt 0 ] && append args '-s'
        [ $enable_edp -gt 0 ] && append args '-e'
 
-       user_exists  lldp 121 || user_add  lldp 121 129
-       group_exists lldp 129 || group_add lldp 129
-
        mkdir -p /var/run/lldp
        chown lldp:lldp /var/run/lldp