procd: update to latest git
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Sep 2014 12:28:00 +0000 (12:28 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Sep 2014 12:28:00 +0000 (12:28 +0000)
add support for starting services as !root

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42471 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/procd/Makefile
package/system/procd/files/procd.sh

index 1f4d7d0..451b925 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2014-08-29
+PKG_VERSION:=2014-09-09
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=6a6fa0a6067cb3c522f5dc735e808a68f62b30b2
+PKG_SOURCE_VERSION:=4bd633868e3284659668f14aa39ea84aaadc2dec
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
index e4e75ed..109daee 100644 (file)
@@ -18,6 +18,7 @@
 #     file: configuration files (array)
 #     netdev: bound network device (detects ifindex changes)
 #     limits: resource limits (passed to the process)
+#     user info: array with 1 values $username
 #
 #   No space separation is done for arrays/tables - use one function argument per command line argument
 #
@@ -139,6 +140,9 @@ _procd_set_param() {
                nice)
                        json_add_int "$type" "$1"
                ;;
+               user)
+                       json_add_string "$type" "$1"
+               ;;
        esac
 }