mac80211: select relayfs if ath9k debugfs is enabled
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Feb 2013 12:12:39 +0000 (12:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Feb 2013 12:12:39 +0000 (12:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35757 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile

index 6ec80b1..0af2c52 100644 (file)
@@ -85,6 +85,7 @@ define KernelPackage/mac80211/config
        config PACKAGE_MAC80211_DEBUGFS
                bool "Export mac80211 internals in DebugFS"
                select KERNEL_DEBUG_FS
+               select KERNEL_RELAY if PACKAGE_kmod-ath9k-common
                default y
                help
                  Select this to see extensive information about
@@ -385,7 +386,6 @@ define KernelPackage/ath/config
 
        config PACKAGE_ATH_DEBUG
                bool "Atheros wireless debugging"
-               select KERNEL_RELAY
                help
                  Say Y, if you want to debug atheros wireless drivers.
                  Right now only ath9k makes use of this.