package/kernel: i2c: don't skip built-in modules
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Feb 2013 11:30:30 +0000 (11:30 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Feb 2013 11:30:30 +0000 (11:30 +0000)
Don't skip build-in modules when generating i2c kmod packages, to allow
empty packages to be generated for satisfying dependencies.

Closes #12259.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35755 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/i2c.mk

index e1adafd..e01f937 100644 (file)
@@ -8,7 +8,7 @@
 I2C_MENU:=I2C support
 
 ModuleConfVar=$(word 1,$(subst :,$(space),$(1)))
-ModuleFullPath=$(if $(findstring y,$($(call ModuleConfVar,$(1)))),,$(LINUX_DIR)/$(word 2,$(subst :,$(space),$(1))).ko)
+ModuleFullPath=$(LINUX_DIR)/$(word 2,$(subst :,$(space),$(1))).ko
 ModuleKconfig=$(foreach mod,$(1),$(call ModuleConfVar,$(mod)))
 ModuleFiles=$(foreach mod,$(1),$(call ModuleFullPath,$(mod)))
 ModuleAuto=$(call AutoLoad,$(1),$(foreach mod,$(2),$(basename $(notdir $(call ModuleFullPath,$(mod))))),$(3))