sunxi: re-add rootfs build when no profile is set, fixes #17980, thanks.
authorwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 17:32:36 +0000 (17:32 +0000)
committerwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 17:32:36 +0000 (17:32 +0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42775 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/sunxi/image/Makefile

index 81ba597..e7991cf 100644 (file)
@@ -100,6 +100,8 @@ endef
 define Image/Build
        $(call Image/Build/$(1),$(1))
        $(call Image/Build/Profile/$(PROFILE),$(1))
+       
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
 endef
 
 $(eval $(call BuildImage))