iproute2: add conflict for ip with ip-full
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 17:13:34 +0000 (17:13 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 17:13:34 +0000 (17:13 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42774 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iproute2/Makefile

index b58a5ab..e2f4b02 100644 (file)
@@ -31,7 +31,11 @@ define Package/iproute2/Default
   VARIANT:=$(1)
 endef
 
-Package/ip=$(call Package/iproute2/Default,tiny,Minimal)
+define Package/ip
+$(call Package/iproute2/Default,tiny,Minimal)
+  CONFLICTS:=ip-full
+endef
+
 Package/ip-full=$(call Package/iproute2/Default,full,Full)
 
 define Package/ip/conffiles