kernel: force CONFIG_BT_HCIUART_ATH3K to y
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Oct 2015 00:00:39 +0000 (00:00 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Oct 2015 00:00:39 +0000 (00:00 +0000)
The CONFIG_BT_HCIUART_ATH3K may not be "m", therfore we cannot inherit the
kmod selection state. Force the "CONFIG_BT_HCIUART_ATH3K" symbol to "y" in
order to avoid `warning: symbol value 'm' invalid for BT_HCIUART_ATH3K` and
subsequent kconfig stalls.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47237 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk

index 9ff291d..022410f 100644 (file)
@@ -84,7 +84,7 @@ define KernelPackage/ath3k
   DEPENDS:=+kmod-bluetooth +ar3k-firmware
   KCONFIG:= \
        CONFIG_BT_ATH3K \
-       CONFIG_BT_HCIUART_ATH3K
+       CONFIG_BT_HCIUART_ATH3K=y
   $(call AddDepends/bluetooth)
   FILES:= \
        $(LINUX_DIR)/drivers/bluetooth/ath3k.ko