kernel: remove the dummy kmod-rtc-core-* package, make all rtc drivers depend on...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 May 2012 15:28:13 +0000 (15:28 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 May 2012 15:28:13 +0000 (15:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31778 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/001-depends.mk
package/kernel/modules/other.mk

index aad2939..6c49301 100644 (file)
@@ -33,7 +33,5 @@ endef
 
 
 define AddDepends/rtc
-  DEPENDS+= \
-    +(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-2.6 \
-    +!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-3.x
+  DEPENDS+= @RTC_SUPPORT
 endef
index 3cf1323..ea0e91f 100644 (file)
@@ -736,34 +736,6 @@ endef
 
 $(eval $(call KernelPackage,pwm-gpio))
 
-define KernelPackage/rtc-core-2.6
-  SUBMENU:=$(OTHER_MENU)
-  DEPENDS:=@(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
-  TITLE:=Real Time Clock class support
-  KCONFIG:=CONFIG_RTC_CLASS
-  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-core.ko
-  AUTOLOAD:=$(call AutoLoad,29,rtc-core)
-endef
-
-define KernelPackage/rtc-core-2.6/description
- Generic RTC class support.
-endef
-
-$(eval $(call KernelPackage,rtc-core-2.6))
-
-define KernelPackage/rtc-core-3.x
-  SUBMENU:=$(OTHER_MENU)
-  DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
-  TITLE:=Real Time Clock class support
-  KCONFIG:=CONFIG_RTC_CLASS=y
-endef
-
-define KernelPackage/rtc-core-3.x/description
- Generic RTC class support.
-endef
-
-$(eval $(call KernelPackage,rtc-core-3.x))
-
 define KernelPackage/rtc-pcf8563
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Philips PCF8563/Epson RTC8564 RTC support