target: add a feature flag for RTC support
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 May 2012 15:28:09 +0000 (15:28 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 May 2012 15:28:09 +0000 (15:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31777 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk
scripts/metadata.pl
target/Config.in

index 61ae108..61cdf06 100644 (file)
@@ -183,6 +183,9 @@ ifeq ($(DUMP),1)
     ifneq ($(CONFIG_VGA_CONSOLE)$(CONFIG_FB),)
       FEATURES += display
     endif
+    ifneq ($(CONFIG_RTC_CLASS),)
+      FEATURES += rtc
+    endif
 
     # remove duplicates
     FEATURES:=$(sort $(FEATURES))
index 41e6e9c..d250a71 100755 (executable)
@@ -161,6 +161,7 @@ sub target_config_features(@) {
                /usb/ and $ret .= "\tselect USB_SUPPORT\n";
                /usbgadget/ and $ret .= "\tselect USB_GADGET_SUPPORT\n";
                /pcmcia/ and $ret .= "\tselect PCMCIA_SUPPORT\n";
+               /rtc/ and $ret .= "\tselect RTC_SUPPORT\n";
                /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n";
                /jffs2/ and $ret .= "\tselect USES_JFFS2\n";
                /ext4/ and $ret .= "\tselect USES_EXT4\n";
index 9e0263e..cc42ad1 100644 (file)
@@ -33,6 +33,9 @@ config USB_SUPPORT
 config USB_GADGET_SUPPORT
        bool
 
+config RTC_SUPPORT
+       bool
+
 config BIG_ENDIAN
        bool