kernel: update linux 3.8 to 3.8.12
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 May 2013 08:53:53 +0000 (08:53 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 May 2013 08:53:53 +0000 (08:53 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36576 3c298f89-4303-0410-b956-a3cf2f4a3e73

35 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/brcm63xx/patches-3.8/415-MIPS-BCM63XX-store-the-flash-type-in-global-variable.patch
target/linux/cns21xx/Makefile
target/linux/cns21xx/patches-3.8/104-cns21xx-usb-ehci-support.patch
target/linux/cns3xxx/Makefile
target/linux/ep93xx/Makefile
target/linux/generic/patches-3.8/863-gpiommc.patch
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/ramips/patches-3.8/0128-MIPS-ralink-add-pinmux-driver.patch
target/linux/ramips/patches-3.8/0130-GPIO-MIPS-ralink-adds-ralink-gpio-support.patch
target/linux/ramips/patches-3.8/0136-NET-MIPS-add-ralink-SoC-ethernet-driver.patch
target/linux/ramips/patches-3.8/0204-owrt-MIPS-ralink-add-usb-platform-support.patch
target/linux/ramips/patches-3.8/0209-owrt-GPIO-add-gpio_export_with_name.patch
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/generic/target.mk
target/linux/x86/geos/target.mk
target/linux/xburst/Makefile

index 9575fbe..028be14 100644 (file)
@@ -11,8 +11,8 @@ endif
 ifeq ($(LINUX_VERSION),3.7.10)
   LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
 endif
-ifeq ($(LINUX_VERSION),3.8.11)
-  LINUX_KERNEL_MD5SUM:=3c4f4fc96bf702d1e9dfbf4d4b4cde9d
+ifeq ($(LINUX_VERSION),3.8.12)
+  LINUX_KERNEL_MD5SUM:=a4be720ca9e61445562565856bb5154d
 endif
 ifeq ($(LINUX_VERSION),3.9)
   LINUX_KERNEL_MD5SUM:=4348c9b6b2eb3144d601e87c19d5d909
index 2285bf0..e8c101d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index 3ce41a4..83b238e 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 03589b4..7a412c2 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
 FEATURES:=squashfs jffs2 targz ext2 usb
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 1748f24..13424b9 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index c26d84d..240c342 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index f61867d..4526396 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index 529cbeb..a88882d 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 70026f1..0b407c4 100644 (file)
@@ -96,7 +96,7 @@ Subject: [PATCH 38/59] MIPS: BCM63XX: store the flash type in global variable
        case BCM63XX_FLASH_TYPE_PARALLEL:
                /* read base address of boot chip select (0) */
                val = bcm_mpi_readl(MPI_CSBASE_REG(0));
-@@ -152,7 +165,7 @@ int __init bcm63xx_flash_register(void)
+@@ -154,7 +167,7 @@ int __init bcm63xx_flash_register(void)
                return -ENODEV;
        default:
                pr_err("flash detection failed for BCM%x: %d\n",
index 6afca67..7e2f764 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 067e631..e68974c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1341,6 +1341,11 @@ MODULE_LICENSE ("GPL");
+@@ -1338,6 +1338,11 @@ MODULE_LICENSE ("GPL");
  #define       PLATFORM_DRIVER         ehci_hcd_sead3_driver
  #endif
  
index 40e5d4e..89fe663 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 3e42ac4..1f6c845 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 DEVICE_TYPE:=developerboard
 
index 5f724e0..f275c65 100644 (file)
 +module_exit(gpiommc_modexit);
 --- a/drivers/mmc/host/Kconfig
 +++ b/drivers/mmc/host/Kconfig
-@@ -459,6 +459,31 @@ config MMC_SDHI
+@@ -449,6 +449,31 @@ config MMC_SDHI
          This provides support for the SDHI SD/SDIO controller found in
          SuperH and ARM SH-Mobile SoCs
  
index 2e6573d..53cbc30 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index c074f65..12a3c26 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 DEVICE_TYPE:=developerboard
 
index ddc4126..1415db0 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 035ed1b..b705c7e 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 340db60..cadf665 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 815aeba..de036e4 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index cefea83..7426422 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 06047da..1f2efdc 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 1118923..d4ad0c4 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 4271712..f28115c 100644 (file)
@@ -16,10 +16,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  4 files changed, 81 insertions(+), 1 deletion(-)
  create mode 100644 arch/mips/ralink/pinmux.c
 
-Index: linux-3.8.11/arch/mips/ralink/Makefile
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/Makefile        2013-05-03 17:53:16.612004798 +0200
-+++ linux-3.8.11/arch/mips/ralink/Makefile     2013-05-06 12:29:27.516615708 +0200
+--- a/arch/mips/ralink/Makefile
++++ b/arch/mips/ralink/Makefile
 @@ -6,7 +6,7 @@
  # Copyright (C) 2009-2011 Gabor Juhos <juhosg@openwrt.org>
  # Copyright (C) 2013 John Crispin <blogic@openwrt.org>
@@ -29,22 +27,18 @@ Index: linux-3.8.11/arch/mips/ralink/Makefile
  
  obj-$(CONFIG_SOC_RT288X) += rt288x.o
  obj-$(CONFIG_SOC_RT305X) += rt305x.o
-Index: linux-3.8.11/arch/mips/ralink/common.h
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/common.h        2013-05-03 17:53:16.720004800 +0200
-+++ linux-3.8.11/arch/mips/ralink/common.h     2013-05-06 12:29:27.108615690 +0200
-@@ -50,4 +50,6 @@
+--- a/arch/mips/ralink/common.h
++++ b/arch/mips/ralink/common.h
+@@ -50,4 +50,6 @@ extern void prom_soc_init(struct ralink_
  
  __iomem void *plat_of_remap_node(const char *node);
  
 +void ralink_pinmux(void);
 +
  #endif /* _RALINK_COMMON_H__ */
-Index: linux-3.8.11/arch/mips/ralink/of.c
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/of.c    2013-05-03 17:53:16.780004804 +0200
-+++ linux-3.8.11/arch/mips/ralink/of.c 2013-05-06 12:29:27.108615690 +0200
-@@ -110,6 +110,8 @@
+--- a/arch/mips/ralink/of.c
++++ b/arch/mips/ralink/of.c
+@@ -110,6 +110,8 @@ static int __init plat_of_setup(void)
        if (of_platform_populate(NULL, of_ids, NULL, NULL))
                panic("failed to populate DT\n");
  
@@ -53,10 +47,8 @@ Index: linux-3.8.11/arch/mips/ralink/of.c
        return 0;
  }
  
-Index: linux-3.8.11/arch/mips/ralink/pinmux.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/arch/mips/ralink/pinmux.c     2013-05-06 12:29:41.212616302 +0200
+--- /dev/null
++++ b/arch/mips/ralink/pinmux.c
 @@ -0,0 +1,77 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify it
index e3eeae9..cdff431 100644 (file)
@@ -17,11 +17,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  create mode 100644 arch/mips/include/asm/mach-ralink/gpio.h
  create mode 100644 drivers/gpio/gpio-ralink.c
 
-Index: linux-3.8.11/arch/mips/Kconfig
-===================================================================
---- linux-3.8.11.orig/arch/mips/Kconfig        2013-05-04 13:20:48.399042973 +0200
-+++ linux-3.8.11/arch/mips/Kconfig     2013-05-04 13:20:54.963043258 +0200
-@@ -449,6 +449,7 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -449,6 +449,7 @@ config RALINK
        select SYS_HAS_EARLY_PRINTK
        select HAVE_MACH_CLKDEV
        select CLKDEV_LOOKUP
@@ -29,10 +27,8 @@ Index: linux-3.8.11/arch/mips/Kconfig
  
  config SGI_IP22
        bool "SGI IP22 (Indy/Indigo2)"
-Index: linux-3.8.11/arch/mips/include/asm/mach-ralink/gpio.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/arch/mips/include/asm/mach-ralink/gpio.h      2013-05-04 13:20:54.963043258 +0200
+--- /dev/null
++++ b/arch/mips/include/asm/mach-ralink/gpio.h
 @@ -0,0 +1,24 @@
 +/*
 + *  Ralink SoC GPIO API support
@@ -58,11 +54,9 @@ Index: linux-3.8.11/arch/mips/include/asm/mach-ralink/gpio.h
 +#define gpio_to_irq   __gpio_to_irq
 +
 +#endif /* __ASM_MACH_RALINK_GPIO_H */
-Index: linux-3.8.11/drivers/gpio/Kconfig
-===================================================================
---- linux-3.8.11.orig/drivers/gpio/Kconfig     2013-05-04 13:20:48.399042973 +0200
-+++ linux-3.8.11/drivers/gpio/Kconfig  2013-05-04 13:20:54.963043258 +0200
-@@ -201,6 +201,12 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -201,6 +201,12 @@ config GPIO_PXA
        help
          Say yes here to support the PXA GPIO device
  
@@ -75,11 +69,9 @@ Index: linux-3.8.11/drivers/gpio/Kconfig
  config GPIO_SPEAR_SPICS
        bool "ST SPEAr13xx SPI Chip Select as GPIO support"
        depends on PLAT_SPEAR
-Index: linux-3.8.11/drivers/gpio/Makefile
-===================================================================
---- linux-3.8.11.orig/drivers/gpio/Makefile    2013-05-04 13:20:48.399042973 +0200
-+++ linux-3.8.11/drivers/gpio/Makefile 2013-05-04 13:20:54.963043258 +0200
-@@ -54,6 +54,7 @@
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -54,6 +54,7 @@ obj-$(CONFIG_GPIO_PCF857X)   += gpio-pcf85
  obj-$(CONFIG_GPIO_PCH)                += gpio-pch.o
  obj-$(CONFIG_GPIO_PL061)      += gpio-pl061.o
  obj-$(CONFIG_GPIO_PXA)                += gpio-pxa.o
@@ -87,10 +79,8 @@ Index: linux-3.8.11/drivers/gpio/Makefile
  obj-$(CONFIG_GPIO_RC5T583)    += gpio-rc5t583.o
  obj-$(CONFIG_GPIO_RDC321X)    += gpio-rdc321x.o
  obj-$(CONFIG_PLAT_SAMSUNG)    += gpio-samsung.o
-Index: linux-3.8.11/drivers/gpio/gpio-ralink.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/drivers/gpio/gpio-ralink.c    2013-05-06 11:39:24.816485479 +0200
+--- /dev/null
++++ b/drivers/gpio/gpio-ralink.c
 @@ -0,0 +1,182 @@
 +/*
 + * This program is free software; you can redistribute it and/or modify it
index 66abc8b..9bb9b5f 100644 (file)
@@ -26,10 +26,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  create mode 100644 drivers/net/ethernet/ramips/ramips_eth.h
  create mode 100644 drivers/net/ethernet/ramips/ramips_main.c
 
-Index: linux-3.8.11/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h       2013-05-06 12:43:38.148652601 +0200
+--- /dev/null
++++ b/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
 @@ -0,0 +1,27 @@
 +/*
 + *  Ralink RT305x SoC platform device registration
@@ -58,11 +56,9 @@ Index: linux-3.8.11/arch/mips/include/asm/mach-ralink/rt305x_esw_platform.h
 +};
 +
 +#endif /* _RT305X_ESW_PLATFORM_H */
-Index: linux-3.8.11/arch/mips/ralink/rt305x.c
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/rt305x.c        2013-05-06 12:43:38.016652594 +0200
-+++ linux-3.8.11/arch/mips/ralink/rt305x.c     2013-05-06 12:43:38.148652601 +0200
-@@ -221,6 +221,7 @@
+--- a/arch/mips/ralink/rt305x.c
++++ b/arch/mips/ralink/rt305x.c
+@@ -221,6 +221,7 @@ void __init ralink_clk_init(void)
        }
  
        ralink_clk_add("cpu", cpu_rate);
@@ -70,11 +66,9 @@ Index: linux-3.8.11/arch/mips/ralink/rt305x.c
        ralink_clk_add("10000b00.spi", sys_rate);
        ralink_clk_add("10000100.timer", wdt_rate);
        ralink_clk_add("10000120.watchdog", wdt_rate);
-Index: linux-3.8.11/drivers/net/ethernet/Kconfig
-===================================================================
---- linux-3.8.11.orig/drivers/net/ethernet/Kconfig     2013-05-01 18:56:10.000000000 +0200
-+++ linux-3.8.11/drivers/net/ethernet/Kconfig  2013-05-06 12:43:38.148652601 +0200
-@@ -136,6 +136,7 @@
+--- a/drivers/net/ethernet/Kconfig
++++ b/drivers/net/ethernet/Kconfig
+@@ -136,6 +136,7 @@ source "drivers/net/ethernet/packetengin
  source "drivers/net/ethernet/pasemi/Kconfig"
  source "drivers/net/ethernet/qlogic/Kconfig"
  source "drivers/net/ethernet/racal/Kconfig"
@@ -82,11 +76,9 @@ Index: linux-3.8.11/drivers/net/ethernet/Kconfig
  source "drivers/net/ethernet/realtek/Kconfig"
  source "drivers/net/ethernet/renesas/Kconfig"
  source "drivers/net/ethernet/rdc/Kconfig"
-Index: linux-3.8.11/drivers/net/ethernet/Makefile
-===================================================================
---- linux-3.8.11.orig/drivers/net/ethernet/Makefile    2013-05-01 18:56:10.000000000 +0200
-+++ linux-3.8.11/drivers/net/ethernet/Makefile 2013-05-06 12:43:38.148652601 +0200
-@@ -54,6 +54,7 @@
+--- a/drivers/net/ethernet/Makefile
++++ b/drivers/net/ethernet/Makefile
+@@ -54,6 +54,7 @@ obj-$(CONFIG_NET_PACKET_ENGINE) += packe
  obj-$(CONFIG_NET_VENDOR_PASEMI) += pasemi/
  obj-$(CONFIG_NET_VENDOR_QLOGIC) += qlogic/
  obj-$(CONFIG_NET_VENDOR_RACAL) += racal/
@@ -94,10 +86,8 @@ Index: linux-3.8.11/drivers/net/ethernet/Makefile
  obj-$(CONFIG_NET_VENDOR_REALTEK) += realtek/
  obj-$(CONFIG_SH_ETH) += renesas/
  obj-$(CONFIG_NET_VENDOR_RDC) += rdc/
-Index: linux-3.8.11/drivers/net/ethernet/ramips/Kconfig
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/drivers/net/ethernet/ramips/Kconfig   2013-05-06 12:43:38.148652601 +0200
+--- /dev/null
++++ b/drivers/net/ethernet/ramips/Kconfig
 @@ -0,0 +1,18 @@
 +config NET_RAMIPS
 +       tristate "Ralink RT288X/RT3X5X/RT3662/RT3883 ethernet driver"
@@ -117,10 +107,8 @@ Index: linux-3.8.11/drivers/net/ethernet/ramips/Kconfig
 +      depends on DEBUG_FS
 +
 +endif
-Index: linux-3.8.11/drivers/net/ethernet/ramips/Makefile
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/drivers/net/ethernet/ramips/Makefile  2013-05-06 12:43:38.148652601 +0200
+--- /dev/null
++++ b/drivers/net/ethernet/ramips/Makefile
 @@ -0,0 +1,9 @@
 +#
 +# Makefile for the Ramips SoCs built-in ethernet macs
@@ -131,10 +119,8 @@ Index: linux-3.8.11/drivers/net/ethernet/ramips/Makefile
 +ramips-$(CONFIG_NET_RAMIPS_DEBUG_FS)  += ramips_debugfs.o
 +
 +obj-$(CONFIG_NET_RAMIPS)      += ramips.o
-Index: linux-3.8.11/drivers/net/ethernet/ramips/ramips_debugfs.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/drivers/net/ethernet/ramips/ramips_debugfs.c  2013-05-06 12:43:38.148652601 +0200
+--- /dev/null
++++ b/drivers/net/ethernet/ramips/ramips_debugfs.c
 @@ -0,0 +1,127 @@
 +/*
 + *  Ralink SoC ethernet driver debugfs code
@@ -263,10 +249,8 @@ Index: linux-3.8.11/drivers/net/ethernet/ramips/ramips_debugfs.c
 +      debugfs_remove(raeth_debugfs_root);
 +      raeth_debugfs_root = NULL;
 +}
-Index: linux-3.8.11/drivers/net/ethernet/ramips/ramips_esw.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/drivers/net/ethernet/ramips/ramips_esw.c      2013-05-06 12:43:38.148652601 +0200
+--- /dev/null
++++ b/drivers/net/ethernet/ramips/ramips_esw.c
 @@ -0,0 +1,1221 @@
 +#include <linux/ioport.h>
 +#include <linux/switch.h>
@@ -1489,10 +1473,8 @@ Index: linux-3.8.11/drivers/net/ethernet/ramips/ramips_esw.c
 +{
 +      platform_driver_unregister(&rt305x_esw_driver);
 +}
-Index: linux-3.8.11/drivers/net/ethernet/ramips/ramips_eth.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/drivers/net/ethernet/ramips/ramips_eth.h      2013-05-06 12:43:38.152652600 +0200
+--- /dev/null
++++ b/drivers/net/ethernet/ramips/ramips_eth.h
 @@ -0,0 +1,375 @@
 +/*
 + *   This program is free software; you can redistribute it and/or modify
@@ -1869,10 +1851,8 @@ Index: linux-3.8.11/drivers/net/ethernet/ramips/ramips_eth.h
 +#endif /* CONFIG_NET_RAMIPS_DEBUG_FS */
 +
 +#endif /* RAMIPS_ETH_H */
-Index: linux-3.8.11/drivers/net/ethernet/ramips/ramips_main.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/drivers/net/ethernet/ramips/ramips_main.c     2013-05-06 13:55:12.572838852 +0200
+--- /dev/null
++++ b/drivers/net/ethernet/ramips/ramips_main.c
 @@ -0,0 +1,1281 @@
 +/*
 + *   This program is free software; you can redistribute it and/or modify
index 30e1b87..0fedc91 100644 (file)
@@ -19,10 +19,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  create mode 100644 arch/mips/ralink/rt305x-usb.c
  create mode 100644 arch/mips/ralink/rt3883-usb.c
 
-Index: linux-3.8.11/arch/mips/ralink/Makefile
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/Makefile        2013-05-06 09:58:57.772224085 +0200
-+++ linux-3.8.11/arch/mips/ralink/Makefile     2013-05-06 10:01:59.252231955 +0200
+--- a/arch/mips/ralink/Makefile
++++ b/arch/mips/ralink/Makefile
 @@ -9,8 +9,8 @@
  obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o
  
@@ -34,22 +32,18 @@ Index: linux-3.8.11/arch/mips/ralink/Makefile
  obj-$(CONFIG_SOC_MT7620) += mt7620.o
  
  obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
-Index: linux-3.8.11/arch/mips/ralink/common.h
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/common.h        2013-05-06 09:58:57.748224086 +0200
-+++ linux-3.8.11/arch/mips/ralink/common.h     2013-05-06 09:58:58.100224099 +0200
-@@ -51,5 +51,6 @@
+--- a/arch/mips/ralink/common.h
++++ b/arch/mips/ralink/common.h
+@@ -51,5 +51,6 @@ extern void prom_soc_init(struct ralink_
  __iomem void *plat_of_remap_node(const char *node);
  
  void ralink_pinmux(void);
 +void ralink_usb_platform(void);
  
  #endif /* _RALINK_COMMON_H__ */
-Index: linux-3.8.11/arch/mips/ralink/mt7620.c
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/mt7620.c        2013-05-06 09:58:57.696224079 +0200
-+++ linux-3.8.11/arch/mips/ralink/mt7620.c     2013-05-06 09:58:58.100224099 +0200
-@@ -140,6 +140,11 @@
+--- a/arch/mips/ralink/mt7620.c
++++ b/arch/mips/ralink/mt7620.c
+@@ -140,6 +140,11 @@ struct ralink_pinmux rt_gpio_pinmux = {
        .uart_mask = MT7620_GPIO_MODE_GPIO,
  };
  
@@ -61,11 +55,9 @@ Index: linux-3.8.11/arch/mips/ralink/mt7620.c
  void __init ralink_clk_init(void)
  {
        unsigned long cpu_rate, sys_rate;
-Index: linux-3.8.11/arch/mips/ralink/of.c
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/of.c    2013-05-06 09:58:57.748224086 +0200
-+++ linux-3.8.11/arch/mips/ralink/of.c 2013-05-06 10:01:59.252231955 +0200
-@@ -111,6 +111,7 @@
+--- a/arch/mips/ralink/of.c
++++ b/arch/mips/ralink/of.c
+@@ -111,6 +111,7 @@ static int __init plat_of_setup(void)
                panic("failed to populate DT\n");
  
        ralink_pinmux();
@@ -73,10 +65,8 @@ Index: linux-3.8.11/arch/mips/ralink/of.c
  
        return 0;
  }
-Index: linux-3.8.11/arch/mips/ralink/rt305x-usb.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/arch/mips/ralink/rt305x-usb.c 2013-05-06 09:58:58.100224099 +0200
+--- /dev/null
++++ b/arch/mips/ralink/rt305x-usb.c
 @@ -0,0 +1,120 @@
 +/*
 + * This program is free software; you can redistribute it and/or modify it
@@ -198,10 +188,8 @@ Index: linux-3.8.11/arch/mips/ralink/rt305x-usb.c
 +                              &rt3352_ehci_data, &rt3352_ehci_dmamask);
 +      }
 +}
-Index: linux-3.8.11/arch/mips/ralink/rt3883-usb.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.8.11/arch/mips/ralink/rt3883-usb.c 2013-05-06 09:58:58.100224099 +0200
+--- /dev/null
++++ b/arch/mips/ralink/rt3883-usb.c
 @@ -0,0 +1,118 @@
 +/*
 + * This program is free software; you can redistribute it and/or modify it
@@ -321,11 +309,9 @@ Index: linux-3.8.11/arch/mips/ralink/rt3883-usb.c
 +      ralink_add_usb("ehci-platform",
 +                      &rt3883_ehci_data, &rt3883_ehci_dmamask);
 +}
-Index: linux-3.8.11/arch/mips/ralink/rt288x.c
-===================================================================
---- linux-3.8.11.orig/arch/mips/ralink/rt288x.c        2013-05-06 09:58:57.644224079 +0200
-+++ linux-3.8.11/arch/mips/ralink/rt288x.c     2013-05-06 10:02:32.216233389 +0200
-@@ -74,6 +74,11 @@
+--- a/arch/mips/ralink/rt288x.c
++++ b/arch/mips/ralink/rt288x.c
+@@ -74,6 +74,11 @@ struct ralink_pinmux rt_gpio_pinmux = {
        .wdt_reset = rt288x_wdt_reset,
  };
  
index 80d9402..c0a1d35 100644 (file)
@@ -14,11 +14,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  include/linux/gpio.h                            |   23 ++++++++-
  5 files changed, 160 insertions(+), 8 deletions(-)
 
-Index: linux-3.8.11/Documentation/devicetree/bindings/gpio/gpio.txt
-===================================================================
---- linux-3.8.11.orig/Documentation/devicetree/bindings/gpio/gpio.txt  2013-05-01 18:56:10.000000000 +0200
-+++ linux-3.8.11/Documentation/devicetree/bindings/gpio/gpio.txt       2013-05-06 12:43:38.252652605 +0200
-@@ -112,3 +112,63 @@
+--- a/Documentation/devicetree/bindings/gpio/gpio.txt
++++ b/Documentation/devicetree/bindings/gpio/gpio.txt
+@@ -112,3 +112,63 @@ where,
  
  The pinctrl node must have "#gpio-range-cells" property to show number of
  arguments to pass with phandle from gpio controllers node.
@@ -82,10 +80,8 @@ Index: linux-3.8.11/Documentation/devicetree/bindings/gpio/gpio.txt
 +              gpio-export,output = <1>;
 +      };
 +};
-Index: linux-3.8.11/drivers/gpio/gpiolib-of.c
-===================================================================
---- linux-3.8.11.orig/drivers/gpio/gpiolib-of.c        2013-05-01 18:56:10.000000000 +0200
-+++ linux-3.8.11/drivers/gpio/gpiolib-of.c     2013-05-06 13:35:56.452788709 +0200
+--- a/drivers/gpio/gpiolib-of.c
++++ b/drivers/gpio/gpiolib-of.c
 @@ -21,6 +21,8 @@
  #include <linux/of_gpio.h>
  #include <linux/pinctrl/pinctrl.h>
@@ -95,7 +91,7 @@ Index: linux-3.8.11/drivers/gpio/gpiolib-of.c
  
  /* Private data structure for of_gpiochip_find_and_xlate */
  struct gg_data {
-@@ -288,3 +290,69 @@
+@@ -288,3 +290,69 @@ void of_gpiochip_remove(struct gpio_chip
        if (chip->of_node)
                of_node_put(chip->of_node);
  }
@@ -165,11 +161,9 @@ Index: linux-3.8.11/drivers/gpio/gpiolib-of.c
 +      return platform_driver_probe(&gpio_export_driver, of_gpio_export_probe);
 +}
 +device_initcall(of_gpio_export_init);
-Index: linux-3.8.11/drivers/gpio/gpiolib.c
-===================================================================
---- linux-3.8.11.orig/drivers/gpio/gpiolib.c   2013-05-01 18:56:10.000000000 +0200
-+++ linux-3.8.11/drivers/gpio/gpiolib.c        2013-05-06 13:31:35.060777376 +0200
-@@ -714,9 +714,10 @@
+--- a/drivers/gpio/gpiolib.c
++++ b/drivers/gpio/gpiolib.c
+@@ -714,9 +714,10 @@ static struct class gpio_class = {
  
  
  /**
@@ -181,7 +175,7 @@ Index: linux-3.8.11/drivers/gpio/gpiolib.c
   * Context: arch_initcall or later
   *
   * When drivers want to make a GPIO accessible to userspace after they
-@@ -728,7 +729,7 @@
+@@ -728,7 +729,7 @@ static struct class gpio_class = {
   *
   * Returns zero on success, else an error.
   */
@@ -190,7 +184,7 @@ Index: linux-3.8.11/drivers/gpio/gpiolib.c
  {
        unsigned long           flags;
        struct gpio_desc        *desc;
-@@ -762,6 +763,8 @@
+@@ -762,6 +763,8 @@ int gpio_export(unsigned gpio, bool dire
                goto fail_unlock;
        }
  
@@ -199,7 +193,7 @@ Index: linux-3.8.11/drivers/gpio/gpiolib.c
        if (!desc->chip->direction_input || !desc->chip->direction_output)
                direction_may_change = false;
        spin_unlock_irqrestore(&gpio_lock, flags);
-@@ -804,7 +807,7 @@
+@@ -804,7 +807,7 @@ fail_unlock:
        pr_debug("%s: gpio%d status %d\n", __func__, gpio, status);
        return status;
  }
@@ -208,7 +202,7 @@ Index: linux-3.8.11/drivers/gpio/gpiolib.c
  
  static int match_export(struct device *dev, void *data)
  {
-@@ -1418,6 +1421,9 @@
+@@ -1418,6 +1421,9 @@ int gpio_request_one(unsigned gpio, unsi
        if (flags & GPIOF_OPEN_SOURCE)
                set_bit(FLAG_OPEN_SOURCE, &gpio_desc[gpio].flags);
  
@@ -218,11 +212,9 @@ Index: linux-3.8.11/drivers/gpio/gpiolib.c
        if (flags & GPIOF_DIR_IN)
                err = gpio_direction_input(gpio);
        else
-Index: linux-3.8.11/include/asm-generic/gpio.h
-===================================================================
---- linux-3.8.11.orig/include/asm-generic/gpio.h       2013-05-01 18:56:10.000000000 +0200
-+++ linux-3.8.11/include/asm-generic/gpio.h    2013-05-06 12:43:38.252652605 +0200
-@@ -204,7 +204,8 @@
+--- a/include/asm-generic/gpio.h
++++ b/include/asm-generic/gpio.h
+@@ -204,7 +204,8 @@ void devm_gpio_free(struct device *dev,
   * A sysfs interface can be exported by individual drivers if they want,
   * but more typically is configured entirely from userspace.
   */
@@ -232,7 +224,7 @@ Index: linux-3.8.11/include/asm-generic/gpio.h
  extern int gpio_export_link(struct device *dev, const char *name,
                        unsigned gpio);
  extern int gpio_sysfs_set_active_low(unsigned gpio, int value);
-@@ -249,7 +250,8 @@
+@@ -249,7 +250,8 @@ struct device;
  
  /* sysfs support is only available with gpiolib, where it's optional */
  
@@ -242,10 +234,8 @@ Index: linux-3.8.11/include/asm-generic/gpio.h
  {
        return -ENOSYS;
  }
-Index: linux-3.8.11/include/linux/gpio.h
-===================================================================
---- linux-3.8.11.orig/include/linux/gpio.h     2013-05-01 18:56:10.000000000 +0200
-+++ linux-3.8.11/include/linux/gpio.h  2013-05-06 13:32:59.796781050 +0200
+--- a/include/linux/gpio.h
++++ b/include/linux/gpio.h
 @@ -27,6 +27,9 @@
  #define GPIOF_EXPORT_DIR_FIXED        (GPIOF_EXPORT)
  #define GPIOF_EXPORT_DIR_CHANGEABLE (GPIOF_EXPORT | GPIOF_EXPORT_CHANGEABLE)
@@ -256,7 +246,7 @@ Index: linux-3.8.11/include/linux/gpio.h
  /**
   * struct gpio - a structure describing a GPIO with configuration
   * @gpio:     the GPIO number
-@@ -189,7 +192,8 @@
+@@ -189,7 +192,8 @@ static inline void gpio_set_value_cansle
        WARN_ON(1);
  }
  
@@ -266,7 +256,7 @@ Index: linux-3.8.11/include/linux/gpio.h
  {
        /* GPIO can never have been requested or set as {in,out}put */
        WARN_ON(1);
-@@ -248,4 +252,24 @@
+@@ -248,4 +252,24 @@ gpiochip_remove_pin_ranges(struct gpio_c
  
  #endif /* ! CONFIG_GENERIC_GPIO */
  
index 2dbfc36..8740b67 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index f92bc47..4b0152f 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 DEVICE_TYPE:=developerboard
 
index e6fd361..7af01fb 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 9588949..e58fdca 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index 5d384a1..bba187c 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME:=Generic
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 define Target/Description
        Build firmware images for x86 based boards
index 30930e9..81af5fb 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index 13c4c6f..6525c83 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio broken
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.8.11
+LINUX_VERSION:=3.8.12
 
 DEVICE_TYPE=other