add support for device type based package preselections
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Sep 2007 21:30:25 +0000 (21:30 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Sep 2007 21:30:25 +0000 (21:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8696 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-defaults.mk

index 88f1c36..40316e0 100644 (file)
@@ -5,12 +5,22 @@
 # See /LICENSE for more information.
 #
 
-# For target profile selection - the default set
-DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd kmod-ipt-nathelper
+# default device type
+DEVICE_TYPE?=router
+
+# Default packages - the really basic set
+DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd mtd
+# For router targets
+DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe iptables kmod-ipt-nathelper bridge
+
+# Additional packages for Linux 2.6
 ifneq ($(KERNEL),2.4)
-  DEFAULT_PACKAGES+=udevtrigger hotplug2
+  DEFAULT_PACKAGES += udevtrigger hotplug2
 endif
 
+# Add device specific packages
+DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
+
 KERNELNAME=
 ifneq (,$(findstring x86,$(BOARD)))
   KERNELNAME="bzImage"