adapt profiles for subtarget changes
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Sep 2007 20:04:43 +0000 (20:04 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Sep 2007 20:04:43 +0000 (20:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8695 3c298f89-4303-0410-b956-a3cf2f4a3e73

21 files changed:
include/target.mk
target/linux/amazon/Makefile
target/linux/amcc/Makefile
target/linux/ar7/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm-2.4/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/etrax/Makefile
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/magicbox/Makefile
target/linux/pxa/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/sibyte/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index 42f484a..8f072d0 100644 (file)
@@ -70,13 +70,17 @@ define Profile
        getvar "$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \
        echo;
-  ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(2),$(2)_)$(1))),y)
+  ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
     PROFILE=$(1)
   endif
 endef
 
-$(eval $(call shexport,Target/Description))
+-include $(PLATFORM_DIR)/profiles/*.mk
+ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+  -include $(PLATFORM_SUBDIR)/profiles/*.mk
+endif
 
+$(eval $(call shexport,Target/Description))
 
 include $(INCLUDE_DIR)/kernel-version.mk
 
index 17f9d96..b8491c2 100644 (file)
@@ -20,7 +20,4 @@ endef
 
 KERNELNAME:="uImage"
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index a35783b..d582d81 100644 (file)
@@ -19,7 +19,4 @@ define Target/Description
        Build firmware images for the AMCC Taishan evaluation board
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index 772222a..a355356 100644 (file)
@@ -19,6 +19,4 @@ define Target/Description
        Build firmware images for TI AR7 based routers
 endef
 
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index 7a9a1ad..dfa3bfb 100644 (file)
@@ -22,7 +22,4 @@ define Target/Description
   Build fimware images for Figment Design Labs VersaLink board.
 endef
 
-#include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index fc48efd..b1a2f57 100644 (file)
@@ -21,7 +21,4 @@ define Target/Description
        Build firmware images for Atheros SoC boards
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index f7dcb03..278e617 100644 (file)
@@ -27,8 +27,5 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
 
index 01d5838..5c7c0bc 100644 (file)
@@ -18,7 +18,4 @@ define Target/Description
   Build firmware images for ATNGW100 board
 endef
 
-#include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index da5cf64..d93e0b6 100644 (file)
@@ -22,7 +22,4 @@ define Target/Description
        (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index 5804ee9..b00d5d7 100644 (file)
@@ -21,7 +21,4 @@ define Target/Description
        (e.g. Netgear WGT634U)
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index 93670c6..0e08984 100644 (file)
@@ -19,7 +19,4 @@ define Target/Description
        (e.g. Inventel Livebox, Siemens SE515)
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index c837550..e644c65 100644 (file)
@@ -34,9 +34,6 @@ define Kernel/Prepare
        $(call Kernel/Prepare/Fox)
 endef
 
-#include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
 $(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
        Please install the binary cris toolchain. \
index c097955..df84078 100644 (file)
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.21.5
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index f68f62b..6e945ab 100644 (file)
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.21.6
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index a20158b..b130095 100644 (file)
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.22.4
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index ad44af2..b5985ea 100644 (file)
@@ -19,7 +19,4 @@ define Target/Description
        Stub for boards based on intel PXA
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index 608f0ac..c80449d 100644 (file)
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.22.4
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index ac49ade..961df47 100644 (file)
@@ -32,7 +32,4 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   endef
 endif
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index aa8acea..52728da 100644 (file)
@@ -15,7 +15,4 @@ LINUX_VERSION:=2.6.21.5
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))
index e31ef02..bed9bc9 100644 (file)
@@ -27,9 +27,6 @@ LINUX_VERSION:=2.6.22.4
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
-
 endif
 
 $(eval $(call BuildTarget))
index 771fd19..d1e459c 100644 (file)
@@ -16,8 +16,5 @@ LINUX_VERSION:=2.6.22.4
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))