build: print missing dependency error to stderr
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jul 2013 11:29:18 +0000 (11:29 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jul 2013 11:29:18 +0000 (11:29 +0000)
Allow to see the actual error even when compiling with V=w/V=1 only.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37388 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-ipkg.mk

index 696de15..522a1de 100644 (file)
@@ -64,8 +64,8 @@ ifneq ($(PKG_NAME),toolchain)
                                echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
                done; \
                if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \
-                       echo "Package $(1) is missing dependencies for the following libraries:"; \
-                       cat "$(PKG_INFO_DIR)/$(1).missing"; \
+                       echo "Package $(1) is missing dependencies for the following libraries:" >&2; \
+                       cat "$(PKG_INFO_DIR)/$(1).missing" >&2; \
                        false; \
                fi; \
        )