include: image.mk: ensure that $(KDIR)/tmp exists in the IB case as well
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 1 Jun 2015 18:00:35 +0000 (18:00 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 1 Jun 2015 18:00:35 +0000 (18:00 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45870 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 36c6c63..020418d 100644 (file)
@@ -464,6 +464,9 @@ define BuildImage
     image_prepare: compile
                mkdir -p $(KDIR)/tmp
                $(call Image/Prepare)
+  else
+    image_prepare:
+               mkdir -p $(KDIR)/tmp
   endif
 
   mkfs_prepare: image_prepare