brcm63xx: delete uncompressed kernels after use
authorJonas Gorski <jogo@openwrt.org>
Mon, 1 Jun 2015 12:37:34 +0000 (12:37 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 1 Jun 2015 12:37:34 +0000 (12:37 +0000)
Delete the dtb appended, uncompressed kernels after having compressed
them, so they don't end in the image builder.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45869 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/image/Makefile

index 139a2e3..cb9bf27 100755 (executable)
@@ -167,6 +167,7 @@ define Image/PrepareLoaderDTB
        # append dtb to vmlinux, then build a standard LZMA loader
        cat $(KDIR)/vmlinux$(1) $(DTS_DIR)/$(2).dtb > $(KDIR)/vmlinux$(1)-$(2)
        $(call Image/PrepareLoader,$(1)-$(2),$(3),$(4))
+       rm -f $(KDIR)/vmlinux$(1)-$(2)
 endef
 
 define Image/PrepareCFELzmaKernel
@@ -198,6 +199,7 @@ define Image/PrepareCFELzmaKernelDTB
        $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(DTS_DIR)/$(1).dtb ../dts/$(1).dts
        cat $(KDIR)/vmlinux $(DTS_DIR)/$(1).dtb > $(KDIR)/vmlinux-$(1)
        $(call Image/PrepareCFELzmaKernel,-$(1))
+       rm -f $(KDIR)/vmlinux-$(1)
 endef
 
 define Image/Prepare