luci-app-fwknop: Adds a check to not overwrite user configured keys 1710/head
authorJonathan Bennett <jbennett@incomsystems.biz>
Sat, 14 Oct 2017 04:39:51 +0000 (23:39 -0500)
committerguidosarducci <guidosarducci@users.noreply.github.com>
Fri, 30 Mar 2018 03:22:41 +0000 (20:22 -0700)
Signed-off-by: Jonathan Bennett <JBennett@Incomsystems.biz>
[Tony Ambardar: backported from master branch 4b7a0085 ("luci-app-fwknop:
                Adds a check to not overwrite user configured keys")]
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
applications/luci-app-fwknopd/Makefile
applications/luci-app-fwknopd/root/etc/uci-defaults/40_luci-fwknopd

index 3fbd88a..6df5a47 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=Fwknopd config - web config for the firewall knock daemon
 LUCI_DEPENDS:=+fwknopd +qrencode
 PKG_VERSION:=1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=GPLv2
 PKG_MAINTAINER:=Jonathan Bennett <JBennett@incomsystems.biz>
 include ../../luci.mk
index 65ef012..9e5057e 100644 (file)
@@ -3,6 +3,7 @@
 #-- Licensed to the public under the GNU General Public License v2.
 . /lib/functions/network.sh
 
+[ "$(uci -q get fwknopd.@access[0].KEY)" != "CHANGEME" ] && exit 0
 uci batch <<EOF
        add ucitrack fwknopd
        set ucitrack.@fwknopd[-1].init=fwknopd