brcm47xx: fix padding of trx images, padjffs2 does not work properly on empty files...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 Aug 2011 21:23:51 +0000 (21:23 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 Aug 2011 21:23:51 +0000 (21:23 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28125 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm47xx/image/Makefile

index bc2ff3a..f7cce16 100644 (file)
@@ -20,7 +20,7 @@ define Image/Prepare
                clean install
        echo -ne "\\x00" >> $(KDIR)/loader.gz
        rm -f $(KDIR)/fs_mark
-       touch $(KDIR)/fs_mark
+       echo -ne '\xde\xad\xc0\xde' > $(KDIR)/fs_mark
        $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
 endef