[PATCH 2/2] Send ipkg-make-index.sh output to stdout
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Feb 2011 22:59:57 +0000 (22:59 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Feb 2011 22:59:57 +0000 (22:59 +0000)
The "Generating index for package" created by ipkg-make-index only
clutter stderr and serve to push previous warnings/errors off-screen.
Instead, send to stdout.

Note:  This would send incorrect invocation messages to stdout as well.
If this is a concern, perhaps we could send them to FD 3, then send 3 to
2...

Signed-off-by: Kevin Locke <klocke@digitalenginesoftware.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25678 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile
target/imagebuilder/files/Makefile

index 8e8c6c9..2180df3 100644 (file)
@@ -89,7 +89,7 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        $(call mklibs)
 
 $(curdir)/index: FORCE
-       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
                gzip -9c Packages > Packages.gz \
        )
 
index 1fa074b..002274a 100644 (file)
@@ -112,7 +112,7 @@ package_index: FORCE
        @echo
        @echo Building package index...
        @mkdir -p $(TOPDIR)/tmp $(TOPDIR)/dl $(TARGET_DIR)/tmp
-       (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+       (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
                gzip -9c Packages > Packages.gz \
        ) >/dev/null 2>/dev/null
        $(OPKG) update