sysupgrade: do not kill any processes in failsafe
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 Jan 2014 22:12:05 +0000 (22:12 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 Jan 2014 22:12:05 +0000 (22:12 +0000)
sysugrade killed the lock causing failsafe to stop

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39318 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/sbin/sysupgrade

index 0160e41..d6c5938 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=149
+PKG_RELEASE:=150
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 56e9a92..e6588bf 100755 (executable)
@@ -210,9 +210,11 @@ run_hooks "" $sysupgrade_pre_upgrade
 ubus call system upgrade
 touch /tmp/sysupgrade
 
-kill_remaining TERM
-sleep 3
-kill_remaining KILL
+if [ ! -f /tmp/failsafe ] ; then
+       kill_remaining TERM
+       sleep 3
+       kill_remaining KILL
+fi
 
 if [ -n "$(rootfs_type)" ]; then
        v "Switching to ramdisk..."