netsupport: l2tp-ip: only depend on IPv6 if IPv6 support is enabled
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 May 2015 13:22:33 +0000 (13:22 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 May 2015 13:22:33 +0000 (13:22 +0000)
Before r45593 kmod-l2tp-ip did not depend on kmod-ipv6.
With r45593 support for L2TP IPv6 encapsulation was added and
included in the kmod-l2tp-ip package. This change also
added the dependency to kmod-ipv6 to kmod-l2tp-ip, regardless
of whether the user chose to generally include IPv6 support
or not.
Change this so L2TP over IPv6 and the resulting dependency
to kmod-ipv6 is only included in kmod-l2tp-ip if IPv6 support
is enabled.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45612 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/netsupport.mk

index 7ec3d29..4483581 100644 (file)
@@ -895,11 +895,13 @@ $(eval $(call KernelPackage,l2tp-eth))
 
 define KernelPackage/l2tp-ip
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=L2TP IP + IPv6 encapsulation for L2TPv3
-  DEPENDS:=+kmod-l2tp +kmod-ipv6
+  TITLE:=L2TP IP encapsulation for L2TPv3
+  DEPENDS:=+kmod-l2tp +IPV6:kmod-ipv6
   KCONFIG:=CONFIG_L2TP_IP
-  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ip.ko $(LINUX_DIR)/net/l2tp/l2tp_ip6.ko
-  AUTOLOAD:=$(call AutoLoad,33,l2tp_ip l2tp_ip6)
+  FILES:= \
+       $(LINUX_DIR)/net/l2tp/l2tp_ip.ko \
+       $(if $(CONFIG_IPV6),$(LINUX_DIR)/net/l2tp/l2tp_ip6.ko)
+  AUTOLOAD:=$(call AutoLoad,33,l2tp_ip $(if $(CONFIG_IPV6),l2tp_ip6))
 endef
 
 define KernelPackage/l2tp-ip/description