ar71xx: add support for ALFA Network's Hornet-UB board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Dec 2011 20:54:10 +0000 (20:54 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Dec 2011 20:54:10 +0000 (20:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29535 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/leds
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-2.6.39
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-hornet-ub.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h

index 3af66b7..c0aadbc 100755 (executable)
@@ -60,6 +60,9 @@ get_status_led() {
        eap7660d)
                status_led="eap7660d:green:ds4"
                ;;
+       hornet-ub)
+               status_led="alfa:blue:wps"
+               ;;
        ja76pf)
                status_led="ja76pf:green:led1"
                ;;
index a0779ef..88538f8 100755 (executable)
@@ -91,6 +91,13 @@ dir-825-b1)
        set_led_usbdev "usb" "USB" "dir825b1:blue:usb" "1-1"
        ;;
 
+hornet-ub)
+       set_led_netdev "lan" "LAN" "alfa:blue:lan" "eth0"
+       set_led_netdev "wan" "WAN" "alfa:blue:wan" "eth1"
+       set_led_wlan "wlan" "WLAN" "alfa:blue:wlan" "phy0tpt"
+       set_led_usbdev "usb" "USB" "alfa:blue:usb" "1-1"
+       ;;
+
 mzk-w04u)
        set_led_usbdev "usb" "USB" "planex:green:usb" "1-1"
        ;;
index c8a202e..83cad36 100755 (executable)
@@ -163,6 +163,9 @@ ar71xx_board_detect() {
        *JWAP003)
                name="jwap003"
                ;;
+       *"Hornet-UB")
+               name="hornet-ub"
+               ;;
        *LS-SR71)
                name="ls-sr71"
                ;;
index d2780a5..2800b05 100755 (executable)
@@ -81,6 +81,7 @@ platform_check_image() {
        ap121-mini | \
        ap96 | \
        db120 | \
+       hornet-ub | \
        zcn-1523h-2 | \
        zcn-1523h-5)
                [ "$magic_long" != "68737173" -a "$magic_long" != "19852003" ] && {
index 068a938..d1870c5 100644 (file)
@@ -24,6 +24,7 @@ CONFIG_AR71XX_MACH_DIR_600_A1=y
 CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
 CONFIG_AR71XX_MACH_EAP7660D=y
+CONFIG_AR71XX_MACH_HORNET_UB=y
 CONFIG_AR71XX_MACH_JA76PF=y
 CONFIG_AR71XX_MACH_JWAP003=y
 CONFIG_AR71XX_MACH_MZK_W04NU=y
index 13d1803..4672861 100644 (file)
@@ -1,6 +1,15 @@
 if ATHEROS_AR71XX
 
 menu "Atheros AR71xx machine selection"
+config AR71XX_MACH_HORNET_UB
+       bool "Alfa Networks Hornet-UB board support"
+       select SOC_AR933X
+       select AR71XX_DEV_M25P80
+       select AR71XX_DEV_GPIO_BUTTONS
+       select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
+       select AR71XX_DEV_AR9XXX_WMAC
+
 config AR71XX_MACH_ALL0258N
        bool "Allnet ALL0258N support"
        select SOC_AR724X
index 2805f19..7723bb0 100644 (file)
@@ -41,6 +41,7 @@ obj-$(CONFIG_AR71XX_MACH_DIR_825_B1)  += mach-dir-825-b1.o
 obj-$(CONFIG_AR71XX_MACH_EAP7660D)     += mach-eap7660d.o
 obj-$(CONFIG_AR71XX_MACH_JA76PF)       += mach-ja76pf.o
 obj-$(CONFIG_AR71XX_MACH_JWAP003)      += mach-jwap003.o
+obj-$(CONFIG_AR71XX_MACH_HORNET_UB)    += mach-hornet-ub.o
 obj-$(CONFIG_AR71XX_MACH_MZK_W04NU)    += mach-mzk-w04nu.o
 obj-$(CONFIG_AR71XX_MACH_MZK_W300NH)   += mach-mzk-w300nh.o
 obj-$(CONFIG_AR71XX_MACH_NBG460N)      += mach-nbg460n.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-hornet-ub.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-hornet-ub.c
new file mode 100644 (file)
index 0000000..6173d22
--- /dev/null
@@ -0,0 +1,134 @@
+/*
+ *  ALFA NETWORKS Hornet-UB board support
+ *
+ *  Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "machtype.h"
+#include "devices.h"
+#include "dev-ar9xxx-wmac.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+
+#define HORNET_UB_GPIO_LED_WLAN                0
+#define HORNET_UB_GPIO_LED_USB         1
+#define HORNET_UB_GPIO_LED_LAN         13
+#define HORNET_UB_GPIO_LED_WAN         17
+#define HORNET_UB_GPIO_LED_WPS         27
+
+#define HORNET_UB_GPIO_BTN_RESET       11
+#define HORNET_UB_GPIO_BTN_WPS         12
+
+#define HORNET_UB_GPIO_USB_POWER       26
+
+#define HORNET_UB_KEYS_POLL_INTERVAL   20      /* msecs */
+#define HORNET_UB_KEYS_DEBOUNCE_INTERVAL       (3 * HORNET_UB_KEYS_POLL_INTERVAL)
+
+#define HORNET_UB_MAC0_OFFSET          0x0000
+#define HORNET_UB_MAC1_OFFSET          0x0006
+#define HORNET_UB_CALDATA_OFFSET       0x1000
+
+static struct gpio_led hornet_ub_leds_gpio[] __initdata = {
+       {
+               .name           = "alfa:blue:lan",
+               .gpio           = HORNET_UB_GPIO_LED_LAN,
+               .active_low     = 0,
+       },
+       {
+               .name           = "alfa:blue:usb",
+               .gpio           = HORNET_UB_GPIO_LED_USB,
+               .active_low     = 0,
+       },
+       {
+               .name           = "alfa:blue:wan",
+               .gpio           = HORNET_UB_GPIO_LED_WAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "alfa:blue:wlan",
+               .gpio           = HORNET_UB_GPIO_LED_WLAN,
+               .active_low     = 0,
+       },
+       {
+               .name           = "alfa:blue:wps",
+               .gpio           = HORNET_UB_GPIO_LED_WPS,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button hornet_ub_gpio_keys[] __initdata = {
+       {
+               .desc           = "WPS button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = HORNET_UB_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = HORNET_UB_GPIO_BTN_WPS,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = HORNET_UB_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = HORNET_UB_GPIO_BTN_RESET,
+               .active_low     = 0,
+       }
+};
+
+static void __init hornet_ub_gpio_setup(void)
+{
+       u32 t;
+
+       ar71xx_gpio_function_disable(AR933X_GPIO_FUNC_ETH_SWITCH_LED0_EN |
+                                    AR933X_GPIO_FUNC_ETH_SWITCH_LED1_EN |
+                                    AR933X_GPIO_FUNC_ETH_SWITCH_LED2_EN |
+                                    AR933X_GPIO_FUNC_ETH_SWITCH_LED3_EN |
+                                    AR933X_GPIO_FUNC_ETH_SWITCH_LED4_EN);
+
+       t = ar71xx_reset_rr(AR933X_RESET_REG_BOOTSTRAP);
+       t |= AR933X_BOOTSTRAP_MDIO_GPIO_EN;
+       ar71xx_reset_wr(AR933X_RESET_REG_BOOTSTRAP, t);
+
+       gpio_request(HORNET_UB_GPIO_USB_POWER, "USB power");
+       gpio_direction_output(HORNET_UB_GPIO_USB_POWER, 1);
+}
+
+static void __init hornet_ub_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+       hornet_ub_gpio_setup();
+
+       ar71xx_add_device_m25p80(NULL);
+       ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(hornet_ub_leds_gpio),
+                                       hornet_ub_leds_gpio);
+       ar71xx_register_gpio_keys_polled(-1, HORNET_UB_KEYS_POLL_INTERVAL,
+                                        ARRAY_SIZE(hornet_ub_gpio_keys),
+                                        hornet_ub_gpio_keys);
+
+       ar71xx_init_mac(ar71xx_eth1_data.mac_addr,
+                       art + HORNET_UB_MAC0_OFFSET, 0);
+       ar71xx_init_mac(ar71xx_eth0_data.mac_addr,
+                       art + HORNET_UB_MAC1_OFFSET, 0);
+
+       ar71xx_add_device_mdio(0, 0x0);
+
+       ar71xx_add_device_eth(1);
+       ar71xx_add_device_eth(0);
+
+       ar9xxx_add_device_wmac(art + HORNET_UB_CALDATA_OFFSET, NULL);
+       ar71xx_add_device_usb();
+}
+
+MIPS_MACHINE(AR71XX_MACH_HORNET_UB, "HORNET-UB", "ALFA NETWORKS Hornet-UB",
+            hornet_ub_setup);
index d3b7fc7..6c93c56 100644 (file)
@@ -30,6 +30,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_EAP7660D,   /* Senao EAP7660D */
        AR71XX_MACH_JA76PF,     /* jjPlus JA76PF */
        AR71XX_MACH_JWAP003,    /* jjPlus JWAP003 */
+       AR71XX_MACH_HORNET_UB,  /* ALFA Networks Hornet-UB */
        AR71XX_MACH_MZK_W04NU,  /* Planex MZK-W04NU */
        AR71XX_MACH_MZK_W300NH, /* Planex MZK-W300NH */
        AR71XX_MACH_NBG460N,    /* Zyxel NBG460N/550N/550NH */