[lantiq] add support for AudioCodes AC-252
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 12 Mar 2013 13:52:54 +0000 (13:52 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 12 Mar 2013 13:52:54 +0000 (13:52 +0000)
user-space support for extracting the EEPROM for the RaLink WiFi is still
missing. Besides this, it's all working.

Signed-off-by: Daniel Golle <dgolle@allnet.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35990 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/base-files/etc/uci-defaults/02_network
target/linux/lantiq/image/ACMP252.dts [new file with mode: 0644]
target/linux/lantiq/image/Makefile
target/linux/lantiq/xway/profiles/audiocodes.mk [new file with mode: 0644]

index db5b58e..1eadb56 100755 (executable)
@@ -47,7 +47,7 @@ ARV4520PW)
        ucidef_add_switch_vlan "eth0" "1" "3 2 1 0 5t"
        ;;
 
-GIGASX76X)
+ACMP252|GIGASX76X)
        ucidef_set_interface_lan "eth0.1"
        ucidef_add_switch "eth0" "1" "1"
        ucidef_add_switch_vlan "eth0" "1" "4 3 2 1 5t"
diff --git a/target/linux/lantiq/image/ACMP252.dts b/target/linux/lantiq/image/ACMP252.dts
new file mode 100644 (file)
index 0000000..174ae2e
--- /dev/null
@@ -0,0 +1,103 @@
+/dts-v1/;
+
+/include/ "danube.dtsi"
+
+/ {
+       model = "ACMP252 - AudioCodes MediaPack MP-252";
+
+       chosen {
+               bootargs = "console=ttyLTQ0,115200 init=/etc/preinit";
+       };
+
+       memory@0 {
+               reg = <0x0 0x4000000>;
+       };
+
+       sram@1F000000 {
+               vmmc@107000 {
+                       status = "okay";
+                       gpios = <&gpio 31 0>;
+               };
+       };
+
+       fpi@10000000 {
+               localbus@0 {
+                       nor-boot@0 {
+                               compatible = "lantiq,nor";
+                               bank-width = <2>;
+                               reg = <0 0x0 0x2000000>;
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               partition@0 {
+                                       label = "uboot";
+                                       reg = <0x0 0x20000>;
+                                       read-only;
+                               };
+
+                               partition@20000 {
+                                       label = "uboot_env";
+                                       reg = <0x20000 0x20000>;
+                               };
+
+                               partition@40000 {
+                                       label = "boardconfig";
+                                       reg = <0x40000 0x60000>;
+                                       read-only;
+                               };
+
+                               partition@a0000 {
+                                       label = "linux";
+                                       reg = <0xa0000 0xf20000>;
+                               };
+
+                               partition@fc0000 {
+                                       label = "sysconfig";
+                                       reg = <0xfc0000 0x40000>;
+                               };
+
+                               partition@0x1000000 {
+                                       label = "rootfs_data";
+                                       reg = <0x1000000 0x1000000>;
+                               };
+
+                       };
+               };
+
+               gpio: pinmux@E100B10 {
+                       pinctrl-names = "default";
+                       pinctrl-0 = <&state_default>;
+
+                       state_default: pinmux {
+                               exin {
+                                       lantiq,groups = "exin1";
+                                       lantiq,function = "exin";
+                               };
+                               pci {
+                                       lantiq,groups = "gnt1", "req1";
+                                       lantiq,function = "pci";
+                               };
+                       };
+               };
+
+               ifxhcd@E101000 {
+                       status = "okay";
+                       gpios = <&gpio 28 0>;
+               };
+
+               etop@E180000 {
+                       phy-mode = "rmii";
+               };
+
+               pci@E105400 {
+                       status = "okay";
+                       interrupt-map = <0x7000 0 0 1 &icu0 135 1>;
+                       req-mask = <0x1>;
+               };
+       };
+
+       ralink_eep {
+               compatible = "ralink,eeprom";
+               ralink,eeprom = "RT2860.eeprom";
+       };
+};
index a68d65b..067767f 100644 (file)
@@ -131,6 +131,9 @@ ifeq ($(CONFIG_TARGET_lantiq_xway),y)
 Image/BuildKernel/Profile/EASY50712=$(call Image/BuildKernel/Template,EASY50712)
 Image/Build/Profile/EASY50712=$(call Image/Build/$(1),$(1),EASY50712)
 
+Image/BuildKernel/Profile/ACMP252=$(call Image/BuildKernel/Template,ACMP252)
+Image/Build/Profile/ACMP252=$(call Image/Build/$(1),$(1),ACMP252)
+
 Image/BuildKernel/Profile/ARV4510PW=$(call Image/BuildKernel/Template,ARV4510PW)
 Image/Build/Profile/ARV4510PW=$(call Image/Build/$(1),$(1),ARV4510PW)
 
diff --git a/target/linux/lantiq/xway/profiles/audiocodes.mk b/target/linux/lantiq/xway/profiles/audiocodes.mk
new file mode 100644 (file)
index 0000000..5f24dfc
--- /dev/null
@@ -0,0 +1,9 @@
+define Profile/ACMP252
+  NAME:=AudioCodes MediaPack MP-252
+  PACKAGES:=kmod-rt2x00 wpad-mini \
+       kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+       kmod-ltq-adsl-danube-fw-a kmod-ltq-ptm-danube \
+       ltq-adsl-app
+endef
+
+$(eval $(call Profile,ACMP252))