libpcap: get rid of some bloat introduced by the update
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Apr 2013 21:07:39 +0000 (21:07 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Apr 2013 21:07:39 +0000 (21:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36151 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/libpcap/Makefile

index 75b5487..f1d2872 100644 (file)
@@ -46,7 +46,8 @@ TARGET_CFLAGS += \
 
 CONFIGURE_VARS += \
        ac_cv_linux_vers=$(LINUX_VERSION) \
-       ac_cv_header_libusb_1_0_libusb_h=no
+       ac_cv_header_libusb_1_0_libusb_h=no \
+       ac_cv_netfilter_can_compile=no
 
 
 CONFIGURE_ARGS += \
@@ -58,7 +59,8 @@ CONFIGURE_ARGS += \
        --with-pcap=linux \
        --without-septel \
        --without-dag \
-       --without-libnl
+       --without-libnl \
+       --disable-can
 
 MAKE_FLAGS += \
        CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include"