ramips: fix Asus RT-N15 board support
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Dec 2011 22:48:42 +0000 (22:48 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Dec 2011 22:48:42 +0000 (22:48 +0000)
Fix Asus RT-N15 flash partitions and make an image.

Signed-off-by: Roman Yeryomin <roman@advem.lv>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29381 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/files/arch/mips/ralink/rt288x/mach-rt-n15.c
target/linux/ramips/image/Makefile

index fb04891..18d5337 100644 (file)
@@ -54,11 +54,11 @@ static struct mtd_partition rt_n15_partitions[] = {
        }, {
                .name   = "kernel",
                .offset = 0x050000,
-               .size   = 0x0b0000,
+               .size   = 0x0d0000,
        }, {
                .name   = "rootfs",
-               .offset = 0x100000,
-               .size   = 0x300000,
+               .offset = 0x120000,
+               .size   = 0x2e0000,
        }, {
                .name   = "firmware",
                .offset = 0x050000,
index 7f0ef00..24f5966 100644 (file)
@@ -258,6 +258,17 @@ define Image/Build/Profile/Default
 endef
 endif
 
+
+define Image/Build/Profile/RTN15
+       $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
+endef
+
+ifeq ($(CONFIG_RALINK_RT288X),y)
+define Image/Build/Profile/Default
+       $(call Image/Build/Profile/RTN15,$(1))
+endef
+endif
+
 define Image/Build/squashfs
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef