add prereq check to prevent people from building openwrt as root
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Aug 2006 18:49:51 +0000 (18:49 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Aug 2006 18:49:51 +0000 (18:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4655 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk

index a6de9b2..e90c315 100644 (file)
@@ -8,6 +8,13 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 
+define Require/non-root
+       [ "$$(shell whoami)" != "root" ]
+endef
+$(eval $(call Require,non-root, \
+       Building OpenWrt as root is not supported! \
+))
+
 # Required for the toolchain
 define Require/working-make
        echo 'all: test' > $(TMP_DIR)/check.mk