Convert portmap to new packaging style
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 May 2005 20:42:22 +0000 (20:42 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 May 2005 20:42:22 +0000 (20:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@896 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/portmap/Makefile
openwrt/package/portmap/ipkg/portmap.control [new file with mode: 0644]
openwrt/package/portmap/portmap.control [deleted file]

index 0cdaa34..e8476ca 100644 (file)
@@ -10,40 +10,26 @@ PKG_MD5SUM:=781e16ed4487c4caa082c6fef09ead4f
 # space separated list or special @SF for sourceforge projects
 PKG_SOURCE_URL:=ftp://ftp.porcupine.org/pub/security
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
-$(DL_DIR)/$(PKG_SOURCE):
-        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PORTMAP,portmap,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PATCH) $(PKG_BUILD_DIR) ./patches
-       touch $(PKG_BUILD_DIR)/.patched
+$(PKG_BUILD_DIR)/.configured:
+       touch $(PKG_BUILD_DIR)/.configured
 
-$(PKG_BUILD_DIR)/portmap: $(PKG_BUILD_DIR)/.patched
+$(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DHOSTS_ACCESS -DFACILITY=LOG_DAEMON -DIGNORE_SIGCHLD" all
+       touch $(PKG_BUILD_DIR)/.built
 
-$(PKG_IPK): $(PKG_BUILD_DIR)/portmap
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin 
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       cp $(PKG_BUILD_DIR)/portmap $(PKG_IPK_DIR)/usr/sbin/
-       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.patched
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
-
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+$(IPKG_PORTMAP):
+       install -d -m0755 $(IDIR_PORTMAP)/usr/sbin 
+       install -m0755 $(PKG_BUILD_DIR)/portmap $(IDIR_PORTMAP)/usr/sbin/
+       $(RSTRIP) $(IDIR_PORTMAP)
+       $(IPKG_BUILD) $(IDIR_PORTMAP) $(PACKAGE_DIR)
diff --git a/openwrt/package/portmap/ipkg/portmap.control b/openwrt/package/portmap/ipkg/portmap.control
new file mode 100644 (file)
index 0000000..55fa61d
--- /dev/null
@@ -0,0 +1,11 @@
+Package: portmap
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: The RPC Portmapper
+ Portmap is a server that converts RPC (Remote Procedure Call) program
+ numbers into DARPA protocol port numbers.  It must be running in order
+ to make RPC calls.
+ .
+ Services that use RPC include NFS and NIS.
diff --git a/openwrt/package/portmap/portmap.control b/openwrt/package/portmap/portmap.control
deleted file mode 100644 (file)
index 55fa61d..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-Package: portmap
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: The RPC Portmapper
- Portmap is a server that converts RPC (Remote Procedure Call) program
- numbers into DARPA protocol port numbers.  It must be running in order
- to make RPC calls.
- .
- Services that use RPC include NFS and NIS.