[package] 6in4: replace sed match with variable substitution, change pattern from...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Sep 2010 16:09:49 +0000 (16:09 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Sep 2010 16:09:49 +0000 (16:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22893 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/6in4/Makefile
package/6in4/files/6in4.hotplug

index c56b9c5..b9fa220 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
 PKG_VERSION:=5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
index b695b52..790edc0 100644 (file)
@@ -32,7 +32,7 @@ if [ "$ACTION" = ifup ]; then
                        config_get password "$cfg" password
 
                        [ -n "$tunnelid" ] && [ -n "$username" ] && [ -n "$password" ] && {
-                               [ "${#password}" != 32 ] || [ -n "$(echo "$password" | sed 's/[a-z0-9]//g')" ] && {
+                               [ "${#password}" == 32 -a -z "${password//[a-f0-9]/}" ] && {
                                        password="$(echo -n "$password" | md5sum)"; password="${password%% *}"
                                }
                                uci_set_state network "$cfg" ipaddr "$wanip"