ar71xx: PowerCloud CAP324 image generation
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Dec 2015 11:27:39 +0000 (11:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Dec 2015 11:27:39 +0000 (11:27 +0000)
Image generation (and mtd partition) part of support for
PowerCloud CAP324 Cloud AP. The CAP324 Cloud AP is a device sold by
PowerCloud Systems who's stock firmware (CloudCommand) provides
'cloud' based managment of large numbers of access points.

The CAP324 is a dual-band 802.11n wireless access point with 16MB flash
and 128MB RAM and single gigabit ethernet port.  It can be powered via
PoE or a power adaptor.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47941 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/generic/profiles/pcs.mk
target/linux/ar71xx/image/Makefile

index 1399ef4..1466e52 100644 (file)
@@ -27,3 +27,23 @@ define Profile/DLRTDEV01/Description
 endef
 
 $(eval $(call Profile,DLRTDEV01))
+
+define Profile/CAP324
+       NAME:=PowerCloud CAP324 Cloud AP
+       PACKAGES:=uboot-envtools
+endef
+
+define Profile/CAP324/Description
+       Package set optimized for the PowerCloud Systems CAP324 Cloud AP
+
+       The CAP324 Cloud AP is a device sold by PowerCloud Systems 
+       who's stock firmware (CloudCommand) provides 'cloud' based
+       managment of large numbers of access points.    
+
+       The CAP324 is a dual-band 802.11n wireless access point with 16MB
+       flash and 128MB RAM and single gigabit ethernet port.  It can be 
+       powered via PoE or a wall wart.
+endef
+
+$(eval $(call Profile,CAP324))
+
index 10de223..5783221 100644 (file)
@@ -392,6 +392,24 @@ define Device/tl-wdr7500-v3
 endef
 TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
 
+define Device/cap324
+  BOARDNAME := CAP324
+  DEVICE_PROFILE := CAP324
+  IMAGE_SIZE = 15296k
+  MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,15296k(firmware),640k(certs),64k(nvram),64k(art)
+endef
+
+TARGET_DEVICES += cap324
+
+define Device/cap324-nocloud
+  BOARDNAME := CAP324
+  DEVICE_PROFILE := CAP324
+  IMAGE_SIZE = 16000k
+  MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,16000k(firmware),64k(art)
+endef
+
+TARGET_DEVICES += cap324-nocloud
+
 define Device/antminer-s1
     $(Device/tplink-8mlzma)
     BOARDNAME := ANTMINER-S1