ar71xx: add TP-Link TL-WA901ND-v4 support
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 9 Apr 2016 10:26:46 +0000 (10:26 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 9 Apr 2016 10:26:46 +0000 (10:26 +0000)
Signed-off-by: Tiziano Bacocco <tizbac2@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49158 3c298f89-4303-0410-b956-a3cf2f4a3e73

12 files changed:
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.1
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa901nd-v4.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/image/Makefile
tools/firmware-utils/src/mktplinkfw.c

index ab19a61..b2469bf 100755 (executable)
@@ -626,6 +626,11 @@ tl-wa901nd-v3)
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
        ;;
 
+tl-wa901nd-v4)
+       ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
+       ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
+       ;;
+
 tl-wr941nd | \
 tl-wr1041n-v2)
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
index c6a2014..8fdfa07 100755 (executable)
@@ -364,6 +364,7 @@ tl-wa801nd-v2 |\
 tl-wa901nd |\
 tl-wa901nd-v2 |\
 tl-wa901nd-v3 |\
+tl-wa901nd-v4 |\
 tl-wr703n |\
 tube2h |\
 unifiac |\
index 1cf6e4c..1f9bd3f 100644 (file)
@@ -305,6 +305,7 @@ get_status_led() {
        tl-wa901nd | \
        tl-wa901nd-v2 | \
        tl-wa901nd-v3 | \
+       tl-wa901nd-v4 | \
        tl-wdr3320-v2 | \
        tl-wdr3500 | \
        tl-wr1041n-v2 | \
index b3eda6c..3d4541e 100755 (executable)
@@ -865,6 +865,9 @@ ar71xx_board_detect() {
        *"TL-WA901ND v3")
                name="tl-wa901nd-v3"
                ;;
+       *"TL-WA901ND v4")
+               name="tl-wa901nd-v4"
+               ;;
        *"TL-WDR3320 v2")
                name="tl-wdr3320-v2"
                ;;
index 86375a9..d44ece5 100755 (executable)
@@ -366,6 +366,7 @@ platform_check_image() {
        tl-wa901nd | \
        tl-wa901nd-v2 | \
        tl-wa901nd-v3 | \
+       tl-wa901nd-v4 | \
        tl-wdr3320-v2 | \
        tl-wdr3500 | \
        tl-wdr4300 | \
index 4dbb6ae..fa98643 100644 (file)
@@ -143,6 +143,7 @@ CONFIG_ATH79_MACH_TL_WA801ND_V3=y
 CONFIG_ATH79_MACH_TL_WA830RE_V2=y
 CONFIG_ATH79_MACH_TL_WA901ND=y
 CONFIG_ATH79_MACH_TL_WA901ND_V2=y
+CONFIG_ATH79_MACH_TL_WA901ND_V4=y
 CONFIG_ATH79_MACH_TL_WAX50RE=y
 CONFIG_ATH79_MACH_TL_WDR3320_V2=y
 CONFIG_ATH79_MACH_TL_WDR3500=y
index a884f35..8c77645 100644 (file)
@@ -1182,6 +1182,15 @@ config ATH79_MACH_TL_WA901ND_V2
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
 
+config ATH79_MACH_TL_WA901ND_V4
+       bool "TP-LINK TL-WA901ND v4 support"
+       select SOC_QCA956X
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_TL_WDR3320_V2
        bool "TP-LINK TL-WDR3320 v2 board support"
        select SOC_AR934X
index 59cc507..862a2e3 100644 (file)
@@ -151,6 +151,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WA830RE_V2)      += mach-tl-wa830re-v2.o
 obj-$(CONFIG_ATH79_MACH_TL_WA801ND_V3)  += mach-tl-wa801nd-v3.o
 obj-$(CONFIG_ATH79_MACH_TL_WA901ND)    += mach-tl-wa901nd.o
 obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V2) += mach-tl-wa901nd-v2.o
+obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V4) += mach-tl-wa901nd-v4.o
 obj-$(CONFIG_ATH79_MACH_TL_WDR3320_V2)  += mach-tl-wdr3320-v2.o
 obj-$(CONFIG_ATH79_MACH_TL_WDR3500)     += mach-tl-wdr3500.o
 obj-$(CONFIG_ATH79_MACH_TL_WDR4300)     += mach-tl-wdr4300.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa901nd-v4.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa901nd-v4.c
new file mode 100644 (file)
index 0000000..9c651bb
--- /dev/null
@@ -0,0 +1,112 @@
+/*
+ *  TP-LINK TL-WA901ND v4 board
+ *
+ *  Copyright (C) 2015 Matthias Schiffer <mschiffer@universe-factory.net>
+ *  Copyright (C) 2016 Tiziano Bacocco <tizbac2@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+
+#define TL_WA901ND_V4_GPIO_LED_QSS             3
+#define TL_WA901ND_V4_GPIO_LED_LAN             7
+#define TL_WA901ND_V4_GPIO_LED_WLAN            8
+#define TL_WA901ND_V4_GPIO_LED_SYSTEM          18
+
+#define TL_WA901ND_V4_GPIO_BTN_RESET           1
+
+#define TL_WA901ND_V4_KEYS_POLL_INTERVAL       20
+#define TL_WA901ND_V4_KEYS_DEBOUNCE_INTERVAL   (3 * TL_WA901ND_V4_KEYS_POLL_INTERVAL)
+
+
+static struct gpio_led TL_WA901ND_V4_leds_gpio[] __initdata = {
+       {
+               .name           = "tp-link:green:qss",
+               .gpio           = TL_WA901ND_V4_GPIO_LED_QSS,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:green:lan",
+               .gpio           = TL_WA901ND_V4_GPIO_LED_LAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:green:wlan",
+               .gpio           = TL_WA901ND_V4_GPIO_LED_WLAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "tp-link:green:system",
+               .gpio           = TL_WA901ND_V4_GPIO_LED_SYSTEM,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button TL_WA901ND_V4_gpio_keys[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = TL_WA901ND_V4_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TL_WA901ND_V4_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }
+};
+
+
+static const char *tl_wa901nd_v4_part_probes[] = {
+       "tp-link",
+       NULL,
+};
+
+static struct flash_platform_data tl_wa901nd_v4_flash_data = {
+       .part_probes    = tl_wa901nd_v4_part_probes,
+};
+
+
+static void __init TL_WA901ND_V4_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       ath79_register_m25p80(&tl_wa901nd_v4_flash_data);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(TL_WA901ND_V4_leds_gpio),
+                                TL_WA901ND_V4_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, TL_WA901ND_V4_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(TL_WA901ND_V4_gpio_keys),
+                                       TL_WA901ND_V4_gpio_keys);
+
+       ath79_register_mdio(0, 0x0);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, -1);
+
+       ath79_switch_data.phy4_mii_en = 1;
+
+       ath79_register_eth(0);
+       ath79_register_eth(1);
+
+       ath79_register_wmac(ee, mac);
+
+}
+
+MIPS_MACHINE(ATH79_MACH_TL_WA901ND_V4, "TL-WA901ND-v4", "TP-LINK TL-WA901ND v4",
+            TL_WA901ND_V4_setup);
index 15e3264..0363c88 100644 (file)
@@ -177,6 +177,7 @@ enum ath79_mach_type {
        ATH79_MACH_TL_WA901ND,          /* TP-LINK TL-WA901ND */
        ATH79_MACH_TL_WA901ND_V2,       /* TP-LINK TL-WA901ND v2 */
        ATH79_MACH_TL_WA901ND_V3,       /* TP-LINK TL-WA901ND v3 */
+       ATH79_MACH_TL_WA901ND_V4,       /* TP-LINK TL-WA901ND v4 */
        ATH79_MACH_TL_WDR3320_V2,       /* TP-LINK TL-WDR3320 v2 */
        ATH79_MACH_TL_WDR3500,          /* TP-LINK TL-WDR3500 */
        ATH79_MACH_TL_WDR4300,          /* TP-LINK TL-WDR4300 */
index cacdd50..e4e2fcf 100644 (file)
@@ -1087,7 +1087,15 @@ define Device/tl-wa901nd-v3
     DEVICE_PROFILE := TLWA901
     TPLINK_HWID := 0x09010003
 endef
-TARGET_DEVICES += tl-wa901nd-v1 tl-wa901nd-v2 tl-wa901nd-v3
+
+define Device/tl-wa901nd-v4
+    $(Device/tplink-4mlzma)
+    BOARDNAME := TL-WA901ND-v4
+    DEVICE_PROFILE := TLWA901
+    TPLINK_HWID := 0x09010004
+endef
+
+TARGET_DEVICES += tl-wa901nd-v1 tl-wa901nd-v2 tl-wa901nd-v3 tl-wa901nd-v4
 
 define Device/tl-wa7210n-v2
     $(Device/tplink-4mlzma)
index 692e48b..bf7c619 100644 (file)
@@ -55,6 +55,7 @@
 #define HWID_TL_WA801ND_V3     0x08010003
 #define HWID_TL_WA901ND_V1     0x09010001
 #define HWID_TL_WA901ND_V2     0x09010002
+#define HWID_TL_WA901ND_V4     0x09010004
 #define HWID_TL_WDR4300_V1_IL  0x43008001
 #define HWID_TL_WDR4900_V1     0x49000001
 #define HWID_TL_WR703N_V1      0x07030101
@@ -316,6 +317,11 @@ static struct board_info boards[] = {
                .hw_rev         = 1,
                .layout_id      = "4M",
        }, {
+               .id             = "TL-WA901NDv4",
+               .hw_id          = HWID_TL_WA901ND_V4,
+               .hw_rev         = 1,
+               .layout_id      = "4Mlzma",
+       }, {
                .id             = "TL-WDR4300v1",
                .hw_id          = HWID_TL_WDR4300_V1_IL,
                .hw_rev         = 1,