x86/soekris: Add defconfig for soekris net4801 and net4826
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 26 Jan 2011 11:33:46 +0000 (11:33 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 26 Jan 2011 11:33:46 +0000 (11:33 +0000)
Add default config file for net4801 and 4826 and initial script
to copy config file like it is done for other platforms.

Patch from: kentarou matsuyama <matsuyama@thinktube.com>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25103 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86/base-files.mk [new file with mode: 0644]
target/linux/x86/base-files/etc/defconfig/net4801/network [new file with mode: 0644]
target/linux/x86/base-files/etc/defconfig/net4826/network [new file with mode: 0644]
target/linux/x86/base-files/etc/init.d/defconfig [new file with mode: 0755]

diff --git a/target/linux/x86/base-files.mk b/target/linux/x86/base-files.mk
new file mode 100644 (file)
index 0000000..29cbfda
--- /dev/null
@@ -0,0 +1,4 @@
+define Package/base-files/install-target
+       rm -f $(1)/etc/config/network
+endef
+
diff --git a/target/linux/x86/base-files/etc/defconfig/net4801/network b/target/linux/x86/base-files/etc/defconfig/net4801/network
new file mode 100644 (file)
index 0000000..ff7b42d
--- /dev/null
@@ -0,0 +1,16 @@
+config interface loopback
+       option ifname   lo
+       option proto    static
+       option ipaddr   127.0.0.1
+       option netmask  255.0.0.0
+
+config interface lan
+       option ifname   eth1
+       option type     bridge
+       option proto    static
+       option ipaddr   192.168.1.1
+       option netmask  255.255.255.0
+
+config interface wan
+       option ifname   eth0
+       option proto    dhcp
diff --git a/target/linux/x86/base-files/etc/defconfig/net4826/network b/target/linux/x86/base-files/etc/defconfig/net4826/network
new file mode 100644 (file)
index 0000000..7c9fb63
--- /dev/null
@@ -0,0 +1,12 @@
+config interface loopback
+       option ifname   lo
+       option proto    static
+       option ipaddr   127.0.0.1
+       option netmask  255.0.0.0
+
+config interface lan
+       option ifname   eth0
+       option type     bridge
+       option proto    static
+       option ipaddr   192.168.1.1
+       option netmask  255.255.255.0
diff --git a/target/linux/x86/base-files/etc/init.d/defconfig b/target/linux/x86/base-files/etc/init.d/defconfig
new file mode 100755 (executable)
index 0000000..4b4f28f
--- /dev/null
@@ -0,0 +1,20 @@
+#!/bin/sh /etc/rc.common
+#
+# Copyright (C) 2010 Thinktube Inc.
+#
+
+START=05
+
+start() {
+       . /lib/soekris.sh
+
+       local board=$(net48xx_board_name)
+
+       [ ! -d /etc/defconfig/$board ] && board="net4826"
+
+       for f in $( ls /etc/defconfig/$board ); do
+               if [ ! -e /etc/config/$f ]; then
+                       cp /etc/defconfig/$board/$f /etc/config/
+               fi
+       done
+}