fix build error in tools on darwin on newer macs (patch by dirtyfreebooter)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Sep 2010 16:16:59 +0000 (16:16 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Sep 2010 16:16:59 +0000 (16:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22934 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host.mk
tools/cloog/Makefile
tools/gmp/Makefile
tools/mpc/Makefile
tools/ppl/Makefile

index 02365d9..8092e8d 100644 (file)
@@ -32,11 +32,12 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                HOST_OS=`uname`; \
                case "$$HOST_OS" in \
                        Linux) HOST_ARCH=`uname -m`;; \
+                       Darwin) HOST_ARCH=`uname -m`;; \
                        *) HOST_ARCH=`uname -p`;; \
                esac; \
                GNU_HOST_NAME=`gcc -dumpmachine`; \
-               [ -n "$$GNU_HOST_NAME" ] || \
-                       GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" == "Darwin" ] && \
+                       GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
                echo "HOST_OS:=$$HOST_OS" > $@; \
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
                echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
index 3bbf812..29b4b73 100644 (file)
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
 
 unexport CFLAGS
 
-ifeq ($(HOST_OS),Darwin)
-  GNU_HOST_NAME:=
-  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
 HOST_CONFIGURE_VARS += \
        LIBS=-lstdc++
 
index f375ada..514187c 100644 (file)
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
 
 unexport CFLAGS
 
-ifeq ($(HOST_OS),Darwin)
-  GNU_HOST_NAME:=
-  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
index 3898830..8f8f07f 100644 (file)
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
 
 unexport CFLAGS
 
-ifeq ($(HOST_OS),Darwin)
-  GNU_HOST_NAME:=
-  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
index c9c09c5..7eea73f 100644 (file)
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
 
 unexport CFLAGS
 
-ifeq ($(HOST_OS),Darwin)
-  GNU_HOST_NAME:=
-  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared