[imagebuilder] populate repositories.conf from version.mk
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Apr 2012 23:08:13 +0000 (23:08 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Apr 2012 23:08:13 +0000 (23:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31268 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/imagebuilder/Makefile
target/imagebuilder/files/repositories.conf

index 3008399..3d04656 100644 (file)
@@ -8,6 +8,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/version.mk
 
 override MAKEFLAGS=
 
@@ -34,7 +35,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
                $(TMP_DIR)/.targetinfo \
                $(TMP_DIR)/.packageinfo \
                $(PKG_BUILD_DIR)/
-       $(SED) 's/$$A/$(BOARD)/' $(PKG_BUILD_DIR)/repositories.conf
+       $(VERSION_SED) $(PKG_BUILD_DIR)/repositories.conf
        $(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
        $(CP) $(STAGING_DIR_HOST)/bin $(PKG_BUILD_DIR)/staging_dir/host/
        $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
index 4a55adb..708855e 100644 (file)
@@ -1,6 +1,6 @@
 ## Place your custom repositories here, they must match the architecture and version.
-# src/gz snapshots http://downloads.openwrt.org/snapshots/trunk/$A/packages
-# src custom file:///usr/src/openwrt/bin/$A/packages
+# src/gz %n %U
+# src custom file:///usr/src/openwrt/bin/%T/packages
 
 ## This is the local package repository, do not remove!
 src imagebuilder file:packages