busybox: use ntp enabled config option
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Jun 2014 07:55:03 +0000 (07:55 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Jun 2014 07:55:03 +0000 (07:55 +0000)
Even if enabled option is missing from ntp configuration we are still keeping
default behavior.

Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41355 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/utils/busybox/Makefile
package/utils/busybox/files/sysntpd

index 6dbd54d..143ad46 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.22.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index c5c3c8e..417addf 100755 (executable)
@@ -8,17 +8,19 @@ PROG=/usr/sbin/ntpd
 
 validate_ntp_section() {
        uci_validate_section system timeserver "${1}" \
-               'server:list(host)' 'enable_server:bool:0'
+               'server:list(host)' 'enabled:bool:1' 'enable_server:bool:0'
 }
 
 start_service() {
-       local server enable_server peer
+       local server enabled enable_server peer
 
        validate_ntp_section ntp || {
                echo "validation failed"
                return 1
        }
 
+       [ $enabled = 0 ] && return
+
        [ -z "$server" ] && return
 
        procd_open_instance