ramips: adding support for OY-0001 Wireless Router
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 14 Jul 2015 07:40:22 +0000 (07:40 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 14 Jul 2015 07:40:22 +0000 (07:40 +0000)
Adding support for OY-0001 Wireless Router.
OY-0001 is a wireless router made by oyewifi.com. Below is the details:
MT7620A, 128MB DDR2, 16MB FLASH, SD Slot, USB 2.0, 4 x LAN + 1 x WAN.

Signed-off-by: Tom Deng <2579131212@qq.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46349 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/OY-0001.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 545bd70..fe3a79d 100755 (executable)
@@ -238,6 +238,10 @@ case $board in
                set_wifi_led "zbtlink:blue:air"
                set_usb_led "zbtlink:blue:usb"
                ;;
+       oy-0001)
+               ucidef_set_led_default "power" "power" "oy:green:power" "1"
+               set_wifi_led "oy:green:wifi"
+               ;;
        wr8305rt)
                ucidef_set_led_default "power" "power" "wr8305rt:sys" "1"
                set_usb_led "wr8305rt:usb"
index bc1fc01..9fb3535 100755 (executable)
@@ -139,6 +139,7 @@ ramips_setup_interfaces()
        mzk-750dhp | \
        whr-300hp2 | \
        whr-600d | \
+       oy-0001 | \
        wsr-600 | \
        wsr-1166 | \
        wt1520 | \
@@ -283,6 +284,11 @@ ramips_setup_macs()
                wan_mac=$(mtd_get_mac_binary devdata 7)
                ;;
 
+       oy-0001)
+               lan_mac=$(mtd_get_mac_binary factory 40)
+               wan_mac=$(mtd_get_mac_binary factory 46)
+               ;;
+
        w306r-v20)
                lan_mac=$(cat /sys/class/net/eth0/address)
                wan_mac=$(macaddr_add "$lan_mac" 5)
index d2a1856..3d40ab9 100755 (executable)
@@ -400,6 +400,9 @@ ramips_board_detect() {
        *"Zbtlink ZBT-WA05")
                name="zbt-wa05"
                ;;
+       *"OY-0001")
+               name="oy-0001"
+               ;;
        *"ZBT WR8305RT")
                name="wr8305rt"
                ;;
index cedd62b..8f45a84 100755 (executable)
@@ -116,6 +116,7 @@ platform_check_image() {
        wr6202 |\
        wr8305rt |\
        wrtnode |\
+       oy-0001 |\
        wt1520 |\
        wt3020 |\
        x5 |\
diff --git a/target/linux/ramips/dts/OY-0001.dts b/target/linux/ramips/dts/OY-0001.dts
new file mode 100644 (file)
index 0000000..48b7099
--- /dev/null
@@ -0,0 +1,123 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "ralink,mt7620a-soc";
+       model = "OY-0001";
+
+        chosen {
+                bootargs = "console=ttyS0,115200";
+        };
+
+       palmbus@10000000 {
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "w25q128";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "w25q128";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "wled", "nd_sd";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               pinctrl-names = "default";
+               pinctrl-0 = <&ephy_pins>;
+
+               ralink,port-map = "llllw";
+       };
+
+       gsw@10110000 {
+               ralink,port4 = "ephy";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               powerled {
+                       label = "oy:green:power";
+                       gpios = <&gpio0 9 1>;
+               };
+               wifiled {
+                       label = "oy:green:wifi";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       sdhci@10130000 {
+               status = "okay";
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       pcie@10140000 {
+               status = "okay";
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               s1 {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
index 0c28216..2fe5fdd 100644 (file)
@@ -866,6 +866,7 @@ Image/Build/Profile/DIR-810L=$(call BuildFirmware/CustomFlash/$(1),$(1),dir-810l
 na930_mtd_size=20971520
 Image/Build/Profile/NA930=$(call BuildFirmware/CustomFlash/$(1),$(1),na930,NA930,$(na930_mtd_size))
 Image/Build/Profile/MZK-750DHP=$(call BuildFirmware/Default8M/$(1),$(1),mzk-750dhp,MZK-750DHP)
+Image/Build/Profile/OY-0001=$(call BuildFirmware/Default16M/$(1),$(1),oy-0001,OY-0001)
 Image/Build/Profile/Y1=$(call BuildFirmware/Default16M/$(1),$(1),Lenovo-y1,Y1)
 Image/Build/Profile/Y1S=$(call BuildFirmware/Default16M/$(1),$(1),Lenovo-y1s,Y1S)
 Image/Build/Profile/MLW221=$(call BuildFirmware/Default16M/$(1),$(1),mlw221,MLW221)
@@ -899,6 +900,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/WHR1166D,$(1))
        $(call Image/Build/Profile/MZK-750DHP,$(1))
        $(call Image/Build/Profile/NA930,$(1))
+       $(call Image/Build/Profile/OY-0001,$(1))
        $(call Image/Build/Profile/Y1,$(1))
        $(call Image/Build/Profile/Y1S,$(1))
        $(call Image/Build/Profile/MLW221,$(1))