procd: make build of upgraded optional
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jan 2015 16:12:52 +0000 (16:12 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jan 2015 16:12:52 +0000 (16:12 +0000)
Update to latest git head in order to support disabling the build
of upgraded which causes linker errors on avr32.

This also adds some fixes to the ubus system.info and system.board
methods.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44134 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/procd/Makefile

index bfb0e00..4f8b2d3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2015-01-09
+PKG_VERSION:=2015-01-25
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=e10fca6b88a8b57fe5a9e80dfd941ae6d98cb970
+PKG_SOURCE_VERSION:=7e6045fe4558e442e97e4a8967f08689d53f2cc4
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -68,6 +68,10 @@ endef
 
 PKG_CONFIG_DEPENDS:= PROCD_SHOW_BOOT PROCD_ZRAM_TMPFS
 
+ifeq ($(CONFIG_NAND_SUPPORT),y)
+  CMAKE_OPTIONS += -DBUILD_UPGRADED=1
+endif
+
 ifeq ($(CONFIG_PROCD_SHOW_BOOT),y)
   CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE=1
 endif