cleanup
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Oct 2006 23:25:32 +0000 (23:25 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Oct 2006 23:25:32 +0000 (23:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5106 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/utils/Makefile
target/utils/src/trx.c

index f2a92fe..8412194 100644 (file)
@@ -27,6 +27,6 @@ $(UTILS_BUILD_DIR):
        mkdir -p $(UTILS_BUILD_DIR)
        
 $(UTILS_BUILD_DIR)/%: src/%.c
-       $(CC) -O2 -I $(STAGING_DIR)/include-host -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
+       $(CC) -O2 -I $(STAGING_DIR)/include-host -include endian.h -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
        chmod 755 $@
 
index abc9bc9..787ffa8 100644 (file)
 #include <string.h>
 #include <errno.h>
 #include <unistd.h>
-#if defined(__APPLE__)
-#include <machine/endian.h>
-#include <machine/byte_order.h>
-#define __BYTE_ORDER BYTE_ORDER
-#define __BIG_ENDIAN BIG_ENDIAN
-#define bswap_16(x) NXSwapShort(x)
-#define bswap_32(x) NXSwapInt(x)
-#define bswap_64(x) NXSwapLongLong(x)
-#else
-#include <endian.h>
-#include <byteswap.h>
-#endif
 
 #if __BYTE_ORDER == __BIG_ENDIAN
 #define STORE32_LE(X)          bswap_32(X)