openssl: to disable mips16, use the new PKG_USE_MIPS16 flag instead of messing with...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Aug 2013 13:02:33 +0000 (13:02 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Aug 2013 13:02:33 +0000 (13:02 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37771 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/openssl/Makefile

index 8b0f524..8f4f93d 100644 (file)
@@ -10,6 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=openssl
 PKG_VERSION:=1.0.1e
 PKG_RELEASE:=2
+PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
@@ -120,7 +121,7 @@ define Build/Configure
        )
 endef
 
-TARGET_CFLAGS := $(filter-out -mips16 -minterlink-mips16,$(TARGET_CFLAGS)) $(FPIC)
+TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
        # XXX: OpenSSL "make depend" will look for installed headers before its own,