[package/hotplug] link hotplug2 against libbsd when eglibc is used
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Jun 2011 13:16:11 +0000 (13:16 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Jun 2011 13:16:11 +0000 (13:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27170 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hotplug2/Makefile

index 7e1dda7..9625ba2 100644 (file)
@@ -28,6 +28,7 @@ define Package/hotplug2
   VERSION:=1.0-beta-$(PKG_RELEASE)
   TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
+  DEPENDS:=+USE_EGLIBC:libbsd
 endef
 
 define Package/hotplug2/description
@@ -44,9 +45,13 @@ MAKE_FLAGS += \
        COPTS="$(TARGET_CFLAGS)" \
        STATIC_WORKER="fork"
 
+ifneq ($(CONFIG_USE_EGLIBC),)
+  TARGET_LDFLAGS += -lbsd
+endif
+
 define Build/Compile
        $(call Build/Compile/Default)
-       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
+       $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
 endef
 
 define Package/hotplug2/install