curl: only set ca path for openssl
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Sep 2014 10:51:56 +0000 (10:51 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Sep 2014 10:51:56 +0000 (10:51 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42662 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/curl/Makefile

index 2c6e6ea..a77fcc8 100644 (file)
@@ -97,7 +97,7 @@ CONFIGURE_ARGS += \
        --disable-manual \
        --disable-verbose \
        --without-ca-bundle \
-       --with-ca-path=/etc/ssl/certs/ \
+       $(if $(CONFIG_LIBCURL_OPENSSL),--with-ca-path=/etc/ssl/certs/) \
        --without-krb4 \
        --without-libidn \
        --without-nss \